Author Topic: Disable automatic parentheses after space  (Read 3271 times)

wyckster

  • Community Member
  • Posts: 6
  • Hero Points: 0
Disable automatic parentheses after space
« on: March 18, 2011, 05:44:19 pm »
When I'm editing a .cc file, and I type if followed by a space, it automatically inserts a pair of parentheses and puts my cursor between them.  How do I turn off this feature so that I can type the parentheses myself?
e.g. I type:
  if (true)

and instead I get:
  if ((true))

I tried turning off: Auto-Completion, and Context Tagging Completion on space, but it still happens.  I can't figure out how to disable that feature.

Can someone help me please?
FYI:
SlickEdit Version 15.0.1.3
OS: Linux
OS VERSION: Ubuntu 9.10



Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Disable automatic parentheses after space
« Reply #1 on: March 18, 2011, 06:03:42 pm »
At Tools > Options > Languages > Application Languages > C/C++ > Indent, uncheck "Syntax Expansion".

wyckster

  • Community Member
  • Posts: 6
  • Hero Points: 0
Re: Disable automatic parentheses after space
« Reply #2 on: March 18, 2011, 07:22:51 pm »
That's it!  Thanks so much, Ryan!

You rock!  :)

Gered

  • Community Member
  • Posts: 27
  • Hero Points: 1
Re: Disable automatic parentheses after space
« Reply #3 on: March 28, 2011, 01:46:09 am »
I had this same problem, and this worked for "if" but didn't change anything for "else". e.g.

if (condition)
{
}
else
    |
    |
cursor is currently here


If I press Enter, it works as expected -- I go to the next line, nothing is automatically added or otherwise changed. However, if I press space, I get this:

if (condition)
{
}
else if ()
         |
         |
   cursor is between parenthesis



Is there some way to disable this behaviour for both "if" and "else"?

If it helps, I'm running the same version as wyckster, but on Gentoo instead of Ubuntu.
« Last Edit: March 28, 2011, 01:48:05 am by Gered »