Author Topic: Broken C/C++ syntax parsing in 15.0.1.3  (Read 2338 times)

jwdonahue

  • Community Member
  • Posts: 10
  • Hero Points: 0
Broken C/C++ syntax parsing in 15.0.1.3
« on: March 21, 2011, 10:16:03 pm »

In the following snippet of code, the first if block is colorized correctly, the second one gets colorized as if everything from the "(*" to the end of the file is a comment.

if ( ( *p) )
{
}

if ( (*p) )
{
}


SlickEdit Version 15.0.1.3

Serial number: <obfuscated>
Licensed number of users: Single user
License file: C:\ProgramData\slickedit\15\slickedit.lic

Build Date: August 04, 2010
Emulation: CUA

OS: Windows 7 x64
OS Version: 6.01.7601  Service Pack 1
Memory: 39% Load, 0MB/4194MB Physical, 174MB/2097MB Virtual
Shell Info: C:\Windows\system32\cmd.exe /q
Screen Size: 1680 x 1050

Project Type: Other
Language: . (C/C++)

Installation Directory: C:\Program Files (x86)\SlickEditV15.0.1\ (non-removable drive,NTFS,195974MB free)
Configuration Directory: C:\Users\<obfuscated>\Documents\My SlickEdit Config\15.0.1\ (non-removable drive,NTFS,195974MB free)

Hotfixes:
C:\Users\<obfuscated>\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_loader_se15013_3.zip (Revision: 3)
C:\Users\<obfuscated>\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_se1501_21_cumulative.zip (Revision: 21)



jwdonahue

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Broken C/C++ syntax parsing in 15.0.1.3
« Reply #1 on: March 23, 2011, 01:25:48 am »
Any chance this is going to get fixed soon?  Having half a files worth of source code colorized as comments because I didn't put a space between the '(' and '*' is very annoying.

chrisant

  • Senior Community Member
  • Posts: 1413
  • Hero Points: 130
Re: Broken C/C++ syntax parsing in 15.0.1.3
« Reply #2 on: March 23, 2011, 09:30:54 am »
Have you confirmed the file buffer's mode is set to C/C++?
Have you made sure the C/C++ language config hasn't somehow gotten Pascal style (* *) comment delimiters added to it?

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Broken C/C++ syntax parsing in 15.0.1.3
« Reply #3 on: March 25, 2011, 03:31:14 pm »
I can't reproduce this issue. I created a new file called test.cpp and pasted the code you provided into it. Everything is colored properly. Are you able to reproduce this using a clean config? To test that, start SlickEdit using the -sc option, as follows: vs -sc <path>, where <path> is a fully qualified path to a location that has never had a config directory in it.

To check the comment configuration as chrisant suggests, go to Tools > Options, then navigate to Languages > Application Languages > C/C++ > Color Coding and click on the Comments tab. You can get there faster by selecting Document > C/C++ Options (assuming the file is being recognized as a C/C++ file). The Document menu contains an entry for the language corresponding to the active file.

jwdonahue

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Broken C/C++ syntax parsing in 15.0.1.3
« Reply #4 on: September 17, 2011, 01:05:41 am »
I gave up on 15.0.1.3 and rolled back to 15.0.0.6.

I have spent thousands of dollars over the years trying to stay current on SlickEdit, VSlick and then SlickEdit again over the past couple of decades.  It seems that lately the expensive upgrades aren't always worth the expense or the trouble.  I think I'll wait until you add support for Win SDK debuggers (Kernel and User mode).  Or maybe I'll just settle for Visual Studio in the future, it's hard on the eyes, but productive.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2107
  • Hero Points: 263
Re: Broken C/C++ syntax parsing in 15.0.1.3
« Reply #5 on: September 21, 2011, 08:03:52 pm »
I think Chrisant has given you the correct solution to the problem you see.  For reasons that we have not yet been able to trace down, we have had 2 or 3 people report that their C/C++ color coding has Pascal style comments in it.  If you go to Document > C/C++ Options > Color Coding > Comments, you should be able to remove the multi-line comment for (* and *) and everything will be fine.

Another quick way to test this is to rename user.vlx in your 15.0.1 configuration directory and restart the editor.