Author Topic: Surround SCM 2011.0.1 Build 23 integration is broken  (Read 3491 times)

Happy Hunter

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Surround SCM 2011.0.1 Build 23 integration is broken
« on: April 08, 2011, 08:28:22 pm »
I'm using SlickEdit Version 15.0.1.3 and recently our source control software from Seapine was updated to 2011.0.1 Build 23.
After this update the integration does not work anymore.

Every time I try to check-out the file I'm getting the message "You must first open a project(Tools...Version Control...Setup)"

Obviously tried and re-tried to do the setup numerous times, but it looks like that SlikEdit does not want to remember settings

The interesting part: the difference option works. It displays the difference between working copy and the file in source control properly.

So somehow the integration is broken only halfway.

PS.
I tried to contact Seapine but they said that it is SlickEdit issue and they will not support me on this topic.


Any suggestions where I can dig/check/look/change etc?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2256
  • Hero Points: 125
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #1 on: April 11, 2011, 05:41:56 pm »
When you open the project does it seem to succeed?  Do you see the name of the project on the dialog after that?

Happy Hunter

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #2 on: April 11, 2011, 06:15:03 pm »
Nop, when you click on Setup->Open Project then the window from Surround SCM appears.

In that window you can choose the workspace and branch, when you click OK the window closes but the project name always stays: NONE

And it does not remember my last choice, if I click "Open Project" again, it starts from the top of the tree.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2256
  • Hero Points: 125
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #3 on: April 11, 2011, 06:24:33 pm »
I would like to put together a debug vsscc.dll for you so that we can try to tell what is going on.  Would you be willing to run a debug version and send me the output?

Happy Hunter

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #4 on: April 11, 2011, 06:28:49 pm »
Sure no problem, I if you need I can even run it under debugger  ;D

Happy Hunter

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #5 on: April 14, 2011, 03:17:13 pm »
Any updates on this?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2256
  • Hero Points: 125
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #6 on: April 14, 2011, 03:18:16 pm »
Sorry for the delay.  I will try to get something out to you today.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2256
  • Hero Points: 125
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #7 on: April 14, 2011, 08:19:18 pm »
Can you PM me an email address to send the DLL to?  I prefer not to post a debug DLL here.

Warren

  • New Community Member
  • Posts: 1
  • Hero Points: -1
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #8 on: September 21, 2011, 01:43:29 pm »
We are having the same problem. Has this been resolved??

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2256
  • Hero Points: 125
Re: Surround SCM 2011.0.1 Build 23 integration is broken
« Reply #9 on: September 21, 2011, 07:02:44 pm »
What version are you using?  Can you also PM me an email address?

Thanks,

Dan