Author Topic: New to 15.0.0.0, trying to set tabs  (Read 2740 times)

MgFrobozz

  • Community Member
  • Posts: 12
  • Hero Points: 0
New to 15.0.0.0, trying to set tabs
« on: April 15, 2011, 06:15:37 pm »
I'm moving from 13.0.0.0 to 15.0.0.1, and trying to figure out how to restore my old settings. 15.0.0.1 has tools section for importing old configurations, but 13.0.0.0 doesn't have one for exporting.

My biggest issue: how do I set tabs to insert 4 spaces? Several times, I've used Tools/Options/Languages/AllLanguages/Indent to set tabs and syntaxindent to 4, after which it asks ...
Quote
You have selected tab stops which differ from the Smart indent amount. Are you sure this is what you want?
I confirm, but the indent still does not insert 4 spaces. If I go back to the indent dialog, it's cleared the syntaxindent setting.

I looked for "Smart indent" in the help search, which led me to "Smart paste", but I can't find anything to set indents for smart paste.

Advice will be most gratefully received!

andymilne

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Re: New to 15.0.0.0, trying to set tabs
« Reply #1 on: December 02, 2016, 10:44:35 pm »
Looks like this same issue is in 21.0.1. I'm having the exact same issue.

andymilne

  • New Community Member
  • Posts: 2
  • Hero Points: 0
Re: New to 15.0.0.0, trying to set tabs
« Reply #2 on: December 02, 2016, 11:03:35 pm »
Ok. I found the fix for setting the tab width:
Tools, QuckStart Configuration, Coding, Set indent for all languages.

Oddly, the default was already 4, but SlickEdit was inserting 3 spaces for me when I hit tab. But, messing with the above option seems to have fixed it for now.

I ran into this issue after selecting the Allman/C/C++ Beautify option. Digging deeper into the Allman settings I see that it defaults to 3 spaces for cases in switch statements - and editing a switch statement was where I noticed the issue. So, that was the root cause of the issue I ran into.