Author Topic: Unexpected tagfile creation behavior with document modes / extensionless headers  (Read 1335 times)

xj97

  • Community Member
  • Posts: 19
  • Hero Points: 1
Hello-

I was seeing some quite odd behavior with my editor (Slick v16.0.1.0), and I solved the problem, although I'd like to post it here in case it could be changed to be a bit more intuitive (or perhaps there was a better way to do this).

We were upgrading to the latest version of OpenSceneGraph (3.0.0), which made the (IMHO) unfortunate choice of using extensionless headers. Anyway, this sequence of events occurred:

 1) Before switching over to new version of OSG 3, I had opened some header files to view some interface changes.
 2) The include directory hadn't been added to my "Extensionless Files" list yet, so they were opened in plain-text mode.
 3) At some point after that, the move to OSG 3 was complete, so I decided to create a tagfile for it.
 4) I tried to get symbol information on one of the classes in the new tagfile, and nothing came up. Upon inspection, my wildcard add of "*." within the include directory had not picked up some (seemingly) random batch of files. Even if I individually hand-selected the files they would not be added to the tagfile. No error was reported.

When I copied the files elsewhere and created a tagfile it went fine, so eventually I figured out the problem was the original opening of the files (before they were added to the Extensionless Files list as a path wildcard). I think the files were closed afterward, but it's possible they were still active buffers when the tagfile was created.

To fix the issue I performed the following steps:

 1) open file, manually change type under "Document" menu.
 2) this adds a specific file entry into "extensionless files" handler.
 3) go into that menu & delete the specific entry (since I've already added it under the Directories with a recursive wildcard).

I am unaware of a way to see what Document Mode all files are set to (either open, or if the mode is cached), so I think I corrected all of the missing files, but I do not feel 100% sure.

It seems to me that perhaps when adding a wildcard/recursive path to the Extensionless File Manager, that it could automatically change any buffer Document modes (open or cached) for the user, or perhaps prompt to do so? There may be other repurcussions with that approach, or a better way to solve this issue, but this threw me for a loop for a bit   ;D

Even just reporting an error back to me when I tried to add the files individually would have saved me some time, although it still would have been a pain to track down which were not added with "Add Tree..." command.

Thanks
Baker