Author Topic: SIGUSR1  (Read 2840 times)

dunkers

  • Senior Community Member
  • Posts: 689
  • Hero Points: 28
SIGUSR1
« on: April 04, 2008, 02:01:52 am »
I'm attempting to debug a remote application running on embedded hardware (Linux, PPC) from a Windows PC running Cygwin. This used to work very well indeed but I've recently added a couple of timers which signal the app via SIGUSR1. Everytime a timer triggers I get a pop-up message in SE saying SIGUSR1 has fired. This effectively stops me doing anything since every time I hit run or step I get this popup.

I've sent a command, via the SE command line, to gdb to variously handle SIGUSR1 as nostop, stop, print, noprint, pass, nopass and all I end up doing is getting rid of the popup message at the expense of not being able to debug the app - hitting the pause button now does nothing whereas before all this it paused the app.

Does SE use SIGUSR1 for debug purposes?

Nathan.Archer@gmail.com

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Re: SIGUSR1
« Reply #1 on: September 01, 2011, 10:44:15 pm »
I'm experiencing the same problem.  Please post a solution if you find one, and I'll do the same.

dunkers

  • Senior Community Member
  • Posts: 689
  • Hero Points: 28
Re: SIGUSR1
« Reply #2 on: September 02, 2011, 08:45:03 am »
Wow! This is going back some :)

I haven't  been near that project for 18 months or so, but as I recall the only fix we found was to disable the timers when we wanted to run the debugger.