Author Topic: Is Recording Macros Broken in 16.0.3?  (Read 1449 times)

lwb78750

  • Community Member
  • Posts: 53
  • Hero Points: 1
  • Senior Software Engineer, C++, Qt, C, etc...
Is Recording Macros Broken in 16.0.3?
« on: October 31, 2011, 03:51:45 pm »
When I try to record a macro and then bind it to a key, I cannot execute the macro from the key and it does not appear (actually none appear) in the "List Macros" dialog.  However, the recorded macro *is* saved in the vusrmacs.e file.  Any idea what might be wrong?

at5dapa1

  • Senior Community Member
  • Posts: 127
  • Hero Points: 8
Re: Is Recording Macros Broken in 16.0.3?
« Reply #1 on: November 01, 2011, 09:17:41 am »
For me it works: 16.0.3+hotfix 2, on XP SP3.
Started recording, stopped recording, saved and assigned key. Key worked.
Listed also in List Macros, from where I could select it for editing and vusermacs.e was opened.

You should try with a clean config, and also post your OS.
When you open Tools-Options-Keys Binding, do you see the key assigned to your macro?
It might be also that some other external app is stealing the key. Did you assign a special key combination?

lwb78750

  • Community Member
  • Posts: 53
  • Hero Points: 1
  • Senior Software Engineer, C++, Qt, C, etc...
Re: Is Recording Macros Broken in 16.0.3?
« Reply #2 on: November 01, 2011, 09:17:46 pm »
Sorry, I'm on Windows 7.
What do I have to do to get a clean config?
Thanks!

hs2

  • Senior Community Member
  • Posts: 2727
  • Hero Points: 281
Re: Is Recording Macros Broken in 16.0.3?
« Reply #3 on: November 01, 2011, 10:39:20 pm »
Just try 'vs.exe -sc C:\Temp' or any other arbitrary directory. - HS2