SlickEdit Product Discussion > SlickEdit®

vsinst (re) installation MFU

(1/2) > >>

jeffcobb:
Hi folks; could use a little help removing my head from someplace dark and stinky. I bought Slickedit 11 for Linux around 6 months ago, installed it on a laptop that is now 'iffy' at best so I am trying to clone my install (or at this point, even a clean installation would be a win if it happens before the other machine goes up in smoke for the last time). After dodgy attempts to clone the settings to a new machine failed spectacularly, I reburned the target box with Ubuntu Edy Eft or whatever the heck 6.10 is. The point is, its a clean install. I popped in the Slickedit disk; it refuses to install as it did earlier. Even though I am root, I keep getting errors about vsinst not being found. I copied the linux folder to the HD, unzipped it, made sure the apps were executable and tried again. This is what the error looks like. Its gotta be something stupid since I see no other folks having any problems with it:

--- Code: ---Script started on Fri 29 Dec 2006 10:53:36 AM PST
jeff@cobb0:~/dev$ cd vsinstall
jeff@cobb0:~/dev/vsinstall$ ls -l
total 110364
-rwxrwxrwx 1 jeff jeff    20046 2006-03-30 14:26 cdinst.vsb
-rwxrwxrwx 1 jeff jeff    10150 2006-03-30 14:11 license.txt
-rw-r--r-- 1 root root        1 2006-12-29 08:27 readme
-rwxrwxrwx 1 jeff jeff     1204 2006-02-06 06:24 readme_ftp.txt
-rwxrwxrwx 1 jeff jeff    33099 2006-03-30 13:48 readme.txt
-rwxrwxrwx 1 jeff jeff 56053522 2006-12-29 08:24 se1100_linux.tar.gz
-rwxrwxrwx 1 jeff jeff   341212 2006-03-30 14:26 unlocksetup
-rwxr-x--- 1 jeff jeff   477464 2006-03-30 14:26 vsinst
-rwxrwxrwx 1 jeff jeff 55924332 2006-03-30 14:11 vspack
jeff@cobb0:~/dev/vsinstall$ sudo ./vsinst
sudo: unable to execute ./vsinst: No such file or directory
jeff@cobb0:~/dev/vsinstall$ sudo bash
root@cobb0:~/dev/vsinstall# ./vsinst
bash: ./vsinst: No such file or directory
root@cobb0:~/dev/vsinstall# exit
exit
jeff@cobb0:~/dev/vsinstall$ exit
exit

Script done on Fri 29 Dec 2006 10:54:13 AM PST



--- End code ---

Unlocksetup acts the same way. Clues?

jeffcobb:
Small follow-up:
as root did a chmod 0777 for everything in the directory, lame-o I know but dammit I am really ready for this thing to work so I can get back to working.   Same results.

Much as I love Emacs, I have been spoiled in some ways by VSE. Scite is getting me by but that requires learning yet ANOTHER new editor programming language, Lua.

Is it possible that the new OS (it originally installed in Ubuntu 5.10) that the apps are not starting due to some runtime linking that the new OS cannot fulfill? I will have at it with ldd to see if that shed any light.

Jeff

jeffcobb:
Don't know if this will help or hinder the situation but usually when I cannot load an ELF based file its because its looking for some .so that I don't have or isn't in my cache. Sorting out what is missing is a case of running ldd against the troublesome file but in this case it complained about my not having some what looks like linker library:

--- Code: ---root@cobb0:~/dev/vsinstall# ldd ./vsinst
/usr/bin/ldd: line 171: /lib/ld-linux.so.2: No such file or directory
ldd: /lib/ld-linux.so.2 exited with unknown exit code (127)
root@cobb0:~/dev/vsinstall# ls /lib/ld-linux.so.2 -l
ls: /lib/ld-linux.so.2: No such file or directory


--- End code ---
Which I find odd because this computer has all of the bin-utils, et al installed, enough to make and build two very large projects (wxWidgets and our own) so its not like there is a bit of the toolchain missing. Still searching for clues.

Jeff

jeffcobb:
Sorry to keep trickling these reports in but I am working very hard to overcome this difficulty with SlickEdit.

As another data point, I have had these exact results on two out of two systems I have tried:
1. AMD64 X2 Running XUbuntu 6.10alt
2. Intel Core Duo (my first intel, know little about product/CPU numbers). Running Ubuntu 6.10

The machine that it *did* install cleanly to back when I first bought it was:
AMD64 X2 Running Ubuntu Breezy (this was a laptop too; I wish some of that breezy-ness had spread over my CPUs some).

IOW, All machines running *some* version of Ubuntu, all machines dual core. The only difference between the intel machine and the rest is that it is 32-bit whereas the rest are obviously not. Being 64-bit did not help machine #1 install SlickEdit....

I will keep digging although I am at a bit of a dead-end wrt the ld-linux.so.2 file..

jeffcobb:
More information:
It seems ld-linux.so.2 does not exist in that folder (or any other) but ld-2.4.so *does* so I tried building a symlink to that in the name of ld-linux.so.2. Stupid thing to do in retrospect since this is a 2.6 kernel but I thought to give it a go since there was also a (this is on a 64-bit box, #1 above) ld-linux-x86_64.so.2 already symlinked to the ld-2.4.so file. I guess, even though it seemed like a brain-damaged attempt to make this SOB install, it was no more brain-damaged than seeing the ld-linux-x86_64.so linked to the ld-2.4.so file.

Short answer is it didn't work but it did change the symptoms:

--- Code: ---jeff@cobb0:~/dev/vsinstall$ sudo bash
Password:
root@cobb0:~/dev/vsinstall# ./vsinst
bash: ./vsinst: Accessing a corrupted shared library
root@cobb0:~/dev/vsinstall# ldd /lib/ld-2.4.so
        statically linked
root@cobb0:~/dev/vsinstall#



--- End code ---

Still no joy but doing what I can to make thing puppy go.

Navigation

[0] Message Index

[#] Next page

Go to full version