Author Topic: What causes: "The following file will always be skipped by auto reload..."  (Read 6928 times)

pmsteinm

  • Senior Community Member
  • Posts: 110
  • Hero Points: 3
I've seen this a few times in my Windows 7 and Linux VS16 sessions:
"The following file will always be skipped by auto reload and auto readonly:"
It shows up in the notification area.  What causes this and what do I do to get the file to not be skipped by auto reload?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2744
  • Hero Points: 145
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #1 on: September 23, 2011, 02:05:00 pm »
This happens when SlickEdit detects that the file takes a long time to reload.  Without this, switching back and forth to the editor when editing a file on a slow file system causes the editor to lock up while waiting on that file.

The default timeout is 5 seconds, and can be adjusted on the options dialog (Tools>Options>File Options>Load).

dfechser

  • Senior Community Member
  • Posts: 123
  • Hero Points: 0
This was useful today! Thanks for keeping it around.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2744
  • Hero Points: 145
Glad to hear it!

JeffB

  • Senior Community Member
  • Posts: 315
  • Hero Points: 14
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #4 on: November 10, 2013, 03:56:23 am »
I see this often when we are having NFS issues.  The problem is with NFS and not a specific file.  Is there a way to view and remove files from the list of files that "will always be skipped" ?

Jeff

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2744
  • Hero Points: 145
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #5 on: November 11, 2013, 01:35:16 pm »
Not really.  You could adjust the time out if you want auto reload to work on the files.  The message should only appear once for each file.

JeffB

  • Senior Community Member
  • Posts: 315
  • Hero Points: 14
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #6 on: November 11, 2013, 02:50:00 pm »
Thanks for the reply, Dan.  Just to be sure I understand....There's a list of files that will never be checked for external changes, but I can't view or change the list of files?

Based on your previous comment, are you saying that adjusting the timeout resets the list and will resore the auto-reload behavior for any files that were previously in the list to be skipped for auto-reload?

Maybe I'm mis-understanding how this feature works, but I'm afraid that I've got files peppered across all my projects that are not being and will never be checked for changes.  Am I wrong here?

Jeff

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2744
  • Hero Points: 145
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #7 on: November 11, 2013, 02:54:51 pm »
The feature works per instance of SlickEdit, it isn't saved between sessions.  When a file takes longer than the auto reload timeout amount to get reload information, the file is "marked" internally and that file is skipped by auto-reload for the remainder of the SlickEdit session.

You can change the amount of time it waits by going to Tools>Options>File Options>Auto reload> Auto reload timeout.  The default is 5000 ms (5 seconds).

Does this clear things up any?

JeffB

  • Senior Community Member
  • Posts: 315
  • Hero Points: 14
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #8 on: November 11, 2013, 03:01:03 pm »
Yes.  Thanks, Dan.

AviManor

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #9 on: February 19, 2014, 10:23:01 am »
How can I revert this?
I want that file to get auto reloaded again.

Graeme

  • Senior Community Member
  • Posts: 2724
  • Hero Points: 337
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #10 on: February 19, 2014, 10:57:02 am »
How can I revert this?
I want that file to get auto reloaded again.

Read Dan's reply (#7) in this thread.

He says
Quote
The feature works per instance of SlickEdit, it isn't saved between sessions.  When a file takes longer than the auto reload timeout amount to get reload information, the file is "marked" internally and that file is skipped by auto-reload for the remainder of the SlickEdit session.

You can change the amount of time it waits by going to Tools>Options>File Options>Auto reload> Auto reload timeout.  The default is 5000 ms (5 seconds).

Does this clear things up any?

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: What causes: "The following file will always be skipped by auto reload..."
« Reply #11 on: February 20, 2014, 12:18:56 am »
In other words, you can revert it by exiting SE and relaunching SE.