Author Topic: #ifdef and #endif are no longer being highlighted  (Read 7008 times)

timur

  • Senior Community Member
  • Posts: 172
  • Hero Points: 3
#ifdef and #endif are no longer being highlighted
« on: January 10, 2007, 09:32:41 pm »
SlickEdit 11 used to highlight the #ifdef and #endif pair whenever the cursor moved over one of them.  It doesn't do that any more.  I can't find any setting or help page that talks about this feature.  How do I turn it back on?

hs2

  • Senior Community Member
  • Posts: 2744
  • Hero Points: 288
Re: #ifdef and #endif are no longer being highlighted
« Reply #1 on: January 10, 2007, 10:55:47 pm »
See the attached screenshot of 'Tools->Options->General Options->More' settings.

HS2

timur

  • Senior Community Member
  • Posts: 172
  • Hero Points: 3
Re: #ifdef and #endif are no longer being highlighted
« Reply #2 on: January 16, 2007, 10:24:05 pm »
I have that option already selected, and yet it still doesn't work.  Do you know what else could be wrong?

It seems that each version of SlickEdit is buggier than the previous.   :(

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: #ifdef and #endif are no longer being highlighted
« Reply #3 on: January 17, 2007, 09:53:20 pm »
I can't reproduce this problem. What version are you using? What language? What OS? Do you have any custom macros installed? Can you reproduce this with a default configuration?

timur

  • Senior Community Member
  • Posts: 172
  • Hero Points: 3
Re: #ifdef and #endif are no longer being highlighted
« Reply #4 on: March 20, 2007, 11:22:02 pm »
I can't reproduce this problem. What version are you using? What language? What OS? Do you have any custom macros installed? Can you reproduce this with a default configuration?
Slickedit 11.0.2
C
Linux
No.

Creating a new configuration fixed the problem.  Thanks.
« Last Edit: March 20, 2007, 11:26:35 pm by timur »