Author Topic: Trailing spaces in aliases with SlickEdit 2012  (Read 2358 times)

jnairb

  • Senior Community Member
  • Posts: 226
  • Hero Points: 11
Trailing spaces in aliases with SlickEdit 2012
« on: June 12, 2012, 03:17:31 pm »
I have an alias defined (for C/C++ files) that expands to a single line with a trailing space. When I enter the alias name and it's expanded, the trailing space is lost. For example, create an alias test with just the single line of "// abc123 : ". When the alias is entered, the cursor is placed immediately after the ':' instead of after the trailing space. (Previous versions would place the cursor after the trailing space.) Changing the alias to "// abc123 : %\c" to explicitly place the cursor following the space, still places the cursor immediately after the ':'.

How do I get the SlickEdit 2011 behavior back?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1397
  • Hero Points: 128
Re: Trailing spaces in aliases with SlickEdit 2012
« Reply #1 on: June 12, 2012, 03:52:44 pm »
A couple of ways you can handle this.  You can disable "Beautify alias expansions" in Tools > Options > Languages > ... > General.  Or you can edit your beautifier profile, and go to Spacing > General and turn off "Remove trailing whitespace". 

The second case you mentioned, where you put a %c on the end should have worked, regardless of the "Remove trailing whitespace" setting.  I'll take a look at that.

jnairb

  • Senior Community Member
  • Posts: 226
  • Hero Points: 11
Re: Trailing spaces in aliases with SlickEdit 2012
« Reply #2 on: June 12, 2012, 04:21:57 pm »
Thanks... disabling "Beautify alias expansions" worked. Turning off the "Remove trailing whitespace" in the profile didn't though.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1397
  • Hero Points: 128
Re: Trailing spaces in aliases with SlickEdit 2012
« Reply #3 on: June 12, 2012, 05:13:34 pm »
Aha, the problem was different from what I imagined it would be, your last update led me right to it.  And just a macro fix at that.  It will be in the first hotfix for 17.0.0.  Thanks for the report.