Author Topic: How can I input Chinese using IBUS in slickedit v17  (Read 1731 times)

zqzou

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
How can I input Chinese using IBUS in slickedit v17
« on: July 09, 2012, 09:58:30 pm »
     Since there is no Ctrl+Space switch for input method editor in slickedit v17 on Linux, how can I activates the IBUS editor to input chinese? Is there any environment variables or other settings in v17 need to be set to enable the IBUS feature on Linux?

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 768
  • Hero Points: 39
Re: How can I input Chinese using IBUS in slickedit v17
« Reply #1 on: July 11, 2012, 02:00:07 pm »
It should work as long as the ibus daemon is running and configured. 

There is an environment variable we look at when we're setting up. Try starting SlickEdit with this command, and see if it works:  XMODIFIERS=@im=ibus /opt/slickedit/bin/vs +new

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 251
  • Hero Points: 23
Re: How can I input Chinese using IBUS in slickedit v17
« Reply #2 on: July 12, 2012, 06:08:09 pm »
To get ibus support to work for Ubuntu and Fedora the following environment variables need to be set:
   XMODIFIERS=@im=ibus
   QT_IM_MODULE=ibus

In 17.0.1, /slickedit/bin/vs is a script (not a binary) so a good place to set these environment variables is in the vs script. (This way other Qt applications are not affected.)

If setting the above environment variables doesn't work, that means that ibus support is either not installed or not active and you can typically enable this in the Keyboard Input Methods settings/dialog of your distro.

On Ubuntu and Fedora, it's very common for XMODIFIERS to be set correctly to "@im=ibus" while QT_IM_MODULE does NOT get set to "ibus". Ubuntu and Fedora have a start-up script that runs to set both of these when you log in. When the script fails to find the Qt ibus support file, it doesn't set QT_IM_MODULE. SlickEdit installs its own Qt ibus support but the script is unaware of it. To fix this, you either need to set the QT_IM_MODULE environment variable or install the Qt ibus package (ibus-qt).