Author Topic: 1701 pasting deletes lines  (Read 1624 times)

Stu

  • Community Member
  • Posts: 57
  • Hero Points: -1
1701 pasting deletes lines
« on: July 29, 2012, 05:24:44 pm »
when I paste a line of code (c/c++ mode), it deletes the line above it or something crazy.

if you paste after an open brace it will delete the previous line. if you paste elsewhere it moves the cursor to the line above.

I think its something funky with the syntax expansion or something.

1701 is quickly becoming unusable for me :/ I feel like going back to v16, at least it was somewhat working. Testing for v17 seems to have been minimal at best.

anyone else seeing funky behaviour when pasting code in c/c++?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4679
  • Hero Points: 377
Re: 1701 pasting deletes lines
« Reply #1 on: August 01, 2012, 09:35:38 pm »
I can't reproduce this.

Some sample code and sample clipboard text would be helpful. Be sure to try a default config and see if you still get the problem (vs -sc c:\temp-config).

Stu

  • Community Member
  • Posts: 57
  • Hero Points: -1
Re: 1701 pasting deletes lines
« Reply #2 on: August 02, 2012, 12:57:35 am »
does not seem to do it with a new config. not sure how to narrow it down. spent an hour import/export options and could not reproduce it, so just exported everything, nuked my 14/15/16/17 option directories and started fresh with an import of my old options and whatever problem it was went away. really weird.