Author Topic: 17.0.1.0 Mac: upgrading SlickEdit does not correctly remember "Indent with Tabs"  (Read 2415 times)

geneg1

  • Community Member
  • Posts: 51
  • Hero Points: 4
Upgrading to 17.0.1.0 (from 17.0.0.8) appeared to have remembered the setting to Indent with Tabs (in Tools > Options > All languages > Formatting). The option was still checked in the dialog, but editing a C++ file immediately after the upgrade revealed that spaces, not tabs, were being inserted into the file.

I had to toggle the option off, Apply, and back on, Apply in order to restore the Indent with Tabs behaviour. I remember that this was a problem for previous upgrades as well (during the v17 beta).

skywise

  • Senior Community Member
  • Posts: 331
  • Hero Points: 10
Ran into this on the PC version when upgrading from 16.0.3 (or whatever the last release of 16 was, not including hot fixes) to 17.0.  Thought it was a one-off of my own so didn't report it.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1471
  • Hero Points: 131
This may sound like a strange question, but what emulations are you running?

geneg1

  • Community Member
  • Posts: 51
  • Hero Points: 4
Xcode.

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Breif

skywise

  • Senior Community Member
  • Posts: 331
  • Hero Points: 10
Brief

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1471
  • Hero Points: 131
Ok, I think I see what's happening, and why I never see it with the emulation I run.  The fix won't be in for 17.0.2, but in the next update.  Thanks for re-reporting it, otherwise I would have assumed one of the 17.0.1 fixes had taken care of it.