Author Topic: Guidlines for using SlickEdit Core for Eclipse with ubuntu 12.04.1  (Read 3600 times)

Stephen

  • Junior Community Member
  • Posts: 2
  • Hero Points: 1
Guidlines for using SlickEdit Core for Eclipse with ubuntu 12.04.1
« on: September 28, 2012, 05:24:36 pm »
I'm in the process of evaluating ubuntu 12.04.1 64-bit as the OS on a embedded development workstation.  Many of our developers like VisualSlick, have used it for many years, and would like to continue.  We also like the idea of using Eclipse for our main editor/debugger environment.  I realize that SlickEdit Core requires the 32-bit installations of both Eclipse and JVM but it seems 'wrong' to limit ourselves to the 32-bit ubuntu just for this reason.  I think we would really like to keep ubuntu as a 64-bit OS but use 32-bit Eclipse and JVM installs.  I've spent some time looking through chatter on the web regarding this approach and it looks to be a little tricky.  Looking for a little guidance before I dive in.  Thanks in advance.

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Guidlines for using SlickEdit Core for Eclipse with ubuntu 12.04.1
« Reply #1 on: September 30, 2012, 01:47:03 pm »
Hi Stephen,
It's not too tricky...the first thing you need to make sure is that you have the 32 bit libraries installed for your Ubuntu system.  There are numerous threads in this forum describing how to do so.  The next step is to install 32 bit java from oracle and 32 bit eclipse.  Then you can modify your eclipse.ini script to make sure it will run with the 32 bit jvm.  This is also described in this forum.  Now you can run this version of eclipse and install slicked it core as normal.  And your system will be using your 64 bit jvm for everything else.

Let me know if you have any other questions.  Look for a 64 bit Linux slickedit core in our next major release.

- Ryan

Stephen

  • Junior Community Member
  • Posts: 2
  • Hero Points: 1
Re: Guidlines for using SlickEdit Core for Eclipse with ubuntu 12.04.1
« Reply #2 on: October 01, 2012, 10:26:27 pm »
Thanks Ryan
When do you projecting the update supporting 64-bit to come out?

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Guidlines for using SlickEdit Core for Eclipse with ubuntu 12.04.1
« Reply #3 on: October 02, 2012, 08:26:23 pm »
I can't really say yet :-\...normally we try to do our yearly major release in late Summer or Fall but this year is a little different because of the large effort required with the QT port.  I can let you know when we get closer to doing beta builds and such.