Author Topic: The pipe character does not work with PC-105 key swedish keyboard on Mac OS X  (Read 4572 times)

Glajan

  • Community Member
  • Posts: 44
  • Hero Points: 7
Hello

I am using an ordinary PC-105 key swedish keyboard with SE 17 on Mac OS X. SE is the only application where the | (pipe) character does not work. When SE was a X11 application I could use setxkbmap on my Mac. However, now when SE is a native Mac OS X application that does not work.

Code: [Select]
SlickEdit 2012 (v17.0.0.

Serial number: FE10037
Licensed number of users: Single user
License file: /Library/Application Support/SlickEdit/17/slickedit.lic

Build Date: June 07, 2012
Emulation: Mac OS X

OS: Mac OS X Lion
OS Version: 10.7.5
Processor Architecture: Intel(R) Core(TM) i7-2760QM CPU @ 2.40GHz 64 bit (8 cores)

Memory: 64% Load, 5322MB/8192MB Virtual
Shell Info: /Applications/SlickEdit2012.app/Contents/MacOS/secsh -i
Screen Size: 1920 x 1200, 1680 x 1050

Project Type: Gnuc
Language: .h (C/C++)

Installation Directory: /Applications/SlickEdit2012.app/Contents/
Configuration Directory: /Users/onorlander/Library/Application Support/SlickEdit/17.0.0/

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
We've been able to replicate this problem, and we're looking into it.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Simple fix. Somewhere in your key bindings there is a command that is bound to Option+7. Go to the Tools > Options dialog, and in the Keyboard and Mouse section, go to the Key Bindings page.
In the "Search by key sequence:" field, type the Option+7 (Pipe) key, and you'll see the text "Option+7" show up in that key sequence field. Below it you'll see the list of commands bound to that key, which I'm guessing will be several instances of "activate-call-stack". Highlight each entry and use the "Remove" button to remove that binding.

Glajan

  • Community Member
  • Posts: 44
  • Hero Points: 7
It works. Thank you  :D