Author Topic: How do I get the repeat key "." to work  (Read 3143 times)

TarDruggan

  • Junior Community Member
  • Posts: 2
  • Hero Points: 1
How do I get the repeat key "." to work
« on: November 02, 2012, 08:43:39 pm »
I've searched and read the forums so if this is somewhere else if you just point out where.
I use the repeat key a lot and it does not seem to work in slickEdit Core. Does anyone know how to configure this to work?
In the same vein but not as important as I can work around it more is that when I go to delete 3 line I usually just issue the command "3dd".
That is also not working.

Thanks

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: How do I get the repeat key "." to work
« Reply #1 on: November 02, 2012, 09:07:04 pm »
Are you using SlickEdit Core 3.7.1?  On Windows 64bit?

The 3dd command should definitely be working...but the . command is a known issue in our Eclipse plugin.  I'll bump the bug report with your information and hopefully we can get it fixed for the next release.  If I can get a hotfix for you in the mean time I will.

As for the reason why 3dd and similar commands wouldn't be working...I'm not really sure ???.  As a test we can try starting Eclipse with a default SlickEdit configuration in order to see if it is something that has gone haywire with your particular config.  To do this, start Eclipse passing the -vsconfig option to the executable, like so:

Code: [Select]
..\eclipse.exe -vsconfig C:\my\new\config

This will create a brand new default configuration at C:\my\new\config.  Let me know if that clears up the problem, and then we can go from there.

- Ryan

TarDruggan

  • Junior Community Member
  • Posts: 2
  • Hero Points: 1
Re: How do I get the repeat key "." to work
« Reply #2 on: November 02, 2012, 09:31:39 pm »
Ryan:

I am running Windows 7 64-bit (I've provided my SlickEdit Core "about" info below). Looking forward to a hotfix for repeat when it is ready.

3dd issue: - Thanks for the tip, working now.

Tar

slickEdit Core info:
=====================
SlickEdit Core v3.7.1 for Eclipse

Library Version: 16.0.3.0 64-bit

Serial number: XXXXXXXXXX
License type: Subscription
License expiration: 2013-10-14 20:00:00
License file: C:\ProgramData\slickeditcore\3.7\slickedit.lic

Build Date: December 01, 2011
Emulation: Vim

Eclipse:  3.7.0.v20110928-1505
JDT:  3.7.2.v201202080800
CDT: 

OS: Windows 7 x64
OS Version: 6.01.7601  Service Pack 1
Memory: 50% Load, 4170MB/8182MB Physical, 4116MB/8180MB Page File, 1374MB/8388607MB Virtual
Shell Info: C:\Windows\system32\cmd.exe /q
Screen Size: 1920 x 1080, 1920 x 1080

Installation Directory: C:\Users\tar\.eclipse\org.eclipse.platform_3.7.0_1433934641\plugins\com.slickedit.windows64.libs_3.7.1\slickedit\ (non-removable drive,NTFS,466904MB free)
Configuration Directory: D:\working\docs\My SlickEdit Core Config\3.7.1\ (non-removable drive,NTFS,371439MB free)

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: How do I get the repeat key "." to work
« Reply #3 on: November 02, 2012, 09:35:13 pm »
Ok...so assuming you can still reproduce the problem with your old config in the old location, you can zip it up and upload it at http://support.slickedit.com/.  Let me know the name of the zip file and I'll see if I can reproduce the problem and see why it occurred with your config.

To export your config to a zip file, go to Window > SlickEdit Preferences > Export/Import Preferences and select Export All Preferences.  Make sure you do this with the config where you are seeing the problem :).

- Ryan