Author Topic: Issues under Eclipse Core  (Read 3953 times)

ctc53

  • Community Member
  • Posts: 11
  • Hero Points: 0
Issues under Eclipse Core
« on: November 08, 2012, 06:49:31 am »
Now I encounter performance problems under Eclipse Core.
The cursor blinks and move slowly. I need to be very patient and be nice to wait.
All this happens only under SlickEdit in Eclipse. The default editor of Eclipse still works fine. UltraEditor(UEX) and SlickEdit (17.02) works fine either. So I am sure my machine is OK.

Beside the SlickEdit 17.02 (standalone) won't start unless I quit the Eclipse.
« Last Edit: November 08, 2012, 06:51:06 am by ctc53 »

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Issues under Eclipse Core
« Reply #1 on: November 12, 2012, 02:29:42 pm »
Sorry you are having such bad performance problems with the plugin.  Can you tell me how your workspace is set up?  For instance, are the files local or do they exist on a network drive somewhere?  Do you have your workspace tagged?  Approximately how many files are in your workspace, and what language(s) are you working with?

One thing to try is to turn off background tagging, which might improve some of the sluggishness you are seeing.  To do this, go to Window > SlickEdit Preferences > Editing > Context Tagging® and set Number of tagging threads to start to 0.  You will then be prompted to restart Eclipse, so go ahead and do this.  After you restart, do you notice any better behavior?

- Ryan