Author Topic: Undo behavior changed in vim mode?  (Read 1352 times)

Ian P

  • Community Member
  • Posts: 59
  • Hero Points: 2
Undo behavior changed in vim mode?
« on: November 13, 2012, 06:32:00 pm »
hi,

Since upgrading to SE 2012 from 2009 I'm seeing a new behavior with undo that I don't like. I use vim mode, and if I make a few changes on a line then type the undo command 'u', it now undoes all the changes that I made on the line rather than just the last one. This is annoying because pretty much every time I only want to undo the last change made and so I then then have to re-do the other edits.

Selecting undo in the menu does not behave like this and it only undoes the last change made.

In SE 2009 'u' would only undo the last change made, so was this a deliberate change in behavior or is it a bug? If its deliberate is there a config option to set it back to how it used to be?

Ian

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Undo behavior changed in vim mode?
« Reply #1 on: November 16, 2012, 06:31:36 pm »
I don't see that undo behavior in 2012...'u' still cycles through my recent changes on the line.  Are you seeing that it will undo multiple character insertions at once?  This can happen...but it's the same behavior as say, Ctrl + z in CUA emulation, for instance.  I checked in 2009 and it still behaves this way in a default configuration.

There are only a few undo options which are exposed...and I don't think any of them would effect the behavior in this way.  Have you tried running 2012 with a default SlickEdit config?  Instead of the one that was copied over from your 2009 installation?  It's probably worth a try...

- Ryan