Author Topic: Search/Find Symbol... doesn't jump to the found location  (Read 1912 times)

mwb1100

  • Senior Community Member
  • Posts: 145
  • Hero Points: 13
Search/Find Symbol... doesn't jump to the found location
« on: November 16, 2012, 11:55:15 pm »
I'm using the Search/Find Symbols... dialog and it seems to find the locations I'm looking for; however, when I double-click on a specific find entry to jump to that file and line all that seems to happen is the Find Symbols dialog goes away.  The cursor is still in the buffer and on the line I was on before I opened the search dialog.

I'm running SE 17.0.2.0 with the 11/15 hotfix package installed (/home/precor/.slickedit/17.0.2/hotfixes/hotfix_se1702_14_cumulative.zip (Revision: 14)).  On Ubuntu 11.04 32-bit.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Search/Find Symbol... doesn't jump to the found location
« Reply #1 on: November 19, 2012, 03:28:12 pm »
Is this happening for all symbols? Try searching for a symbol that would be in your system tag file, like your Java or C++ tags. And then try searching for something that would be only found in your current project or workspace.
I'm thinking perhaps the tag file path info is stale if you've renamed or moved source directories since the tag file was last built.

mwb1100

  • Senior Community Member
  • Posts: 145
  • Hero Points: 13
Re: Search/Find Symbol... doesn't jump to the found location
« Reply #2 on: March 12, 2013, 10:09:25 pm »
Sorry for not responding to this issue in a more timely fashion...  recently I had reason to try this again on a fresh, clean (I believe) project and found a few more bits of information:

If I select an entry in the Symbol List in the "Find Symbol" tool dialog and press enter (or double click the entry) it works fine as long as the target of the jump is not currently open.  However if the file is already open, the cursor is moved to the correct location in that buffer, but the buffer isn't made active. If I use the "Go to definition" button in the dialog (or press F12), the target location is made active (but the "Find Symbol" dialog doesn't go away - is that the expected behavior?).

So in summary, everything seems to work except making the target location's buffer active if the file is already open and I'm trying to navigate by double-clicking or pressing enter on an entry in the Symbol List.

In case it matters, I'm now running SE v17.0.3.0 32-bit with hotfix_se1703_10_cumulative.zip on Ubuntu 12.04
« Last Edit: March 12, 2013, 10:25:17 pm by mwb1100 »

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Search/Find Symbol... doesn't jump to the found location
« Reply #3 on: March 13, 2013, 01:51:32 pm »
The dialog behavior is as expected. Using the toolbar buttons will leave the search dialog active, while double-clicks or pressing Enter will close the dialog (if floating).
Some of these dialog conventions are a bit non-standard, but that's a function of needing them to behave as docked tool windows, as modeless floating windows, and occasionally as modal prompts.