Author Topic: Macro recording defect on Mac  (Read 943 times)

Tommy6502

  • Community Member
  • Posts: 15
  • Hero Points: 2
Macro recording defect on Mac
« on: December 01, 2012, 05:49:28 am »
I'm having lots of problems using macro recording with vim emulation on Mac.  It just doesn't work very well.  Here is an example:

If you have the two lines of code:

    const wxString& getValue() const;
    const wxString& getValue() const;

Position the cursor on the first line of code above.  Do the following in vim mode:
  • Start a macro recording Ctrl-F11
  • Press 0 to go to beginning of line
  • Press the following vim key sequence wdt&xxrs3lyw0j
  • Stop macro recording Ctrl-F11
  • Position cursor on the second line, play macro Ctrl-F12
You get something different from what was recorded, here is what I get:

lst wxString& setValue() const;

It doesn't play back correctly  ???

Here is my program information:

SlickEdit 2012 (v17.0.2.0)

Serial number: FE10403
Licensed number of users: Single user
License file: /Library/Application Support/SlickEdit/17/slickedit.lic

Build Date: August 09, 2012
Emulation: Vim

OS: Mac OS X Lion
OS Version: 10.7.5
Processor Architecture: Intel(R) Core(TM) i7-2760QM CPU @ 2.40GHz 64 bit (8 cores)

Memory: 42% Load, 1731MB/4096MB Virtual
Shell Info: /Applications/SlickEdit2012.app/Contents/MacOS/secsh -i
Screen Size: 1680 x 1050

Project Type: Gnuc
Language: .h (C/C++)

Installation Directory: /Applications/SlickEdit2012.app/Contents/
Configuration Directory: /Users/tommy/Library/Application Support/SlickEdit/17.0.2/