Author Topic: New programming language support  (Read 2693 times)

a.stavonin

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
New programming language support
« on: April 18, 2013, 01:23:52 pm »
Hi all. I've started from your manual for new languages but it's too old as doesn't work any more. First problem is "Load hotfix" returns "Invalid hot fix.  Could not open manifest: File not found".
And second problem is keywords. If I'm loading plugin manually keywords list are greyed but "cload" returns 0, what means successful regarding doc-comments.
So, do you have valid manual?
How can I setup keywords list?

IanG

  • Community Member
  • Posts: 18
  • Hero Points: 0
Re: New programming language support
« Reply #1 on: April 19, 2013, 02:06:04 pm »
Is this problem specifically with loading the LOGO example at the web page you point to?

a.stavonin

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: New programming language support
« Reply #2 on: April 19, 2013, 02:13:32 pm »
The problem exists as with example as with my own language extension (as the extension is based on the example).

IanG

  • Community Member
  • Posts: 18
  • Hero Points: 0
Re: New programming language support
« Reply #3 on: April 19, 2013, 07:33:55 pm »
The problem exists as with example as with my own language extension (as the extension is based on the example).

OK, I am working on a similar project, but I have not tried to make a hotfix yet. Some of my recent discussion is over here:
http://community.slickedit.com/index.php/topic,8923.0.html.

Is your language definition working in the GUI for (e.g.) syntax coloring of keywords?

I think you are way ahead of me in the process, but if you need help with any of these specific items, I might be able help you:
  • Setting up the list of keywords for the lexer, and exporting it to <lexer_name>.vlx file
  • Defining language name, file extensions, lexer name and invoking _CreateLanguage()
As an experiment, I will also try creating a hotfix for my language, although it doesn't support tagging yet. But it will be interesting to see if the hotfix works.
« Last Edit: April 19, 2013, 07:40:26 pm by IanG »