Author Topic: Problems with Perforce client  (Read 12744 times)

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2410
  • Hero Points: 135
Re: Problems with Perforce client
« Reply #15 on: May 06, 2013, 03:44:08 pm »
On a side note, I probably would have had this info sooner, but when attempting to use the file backup history to clean out extraneous debug statements I had added, the diff view was unusable.  The cursor is constantly flickering, whether trying to edit text or click the window buttons.  Not sure if someone has already mentioned this behavior yet or not.

I thought this was a KDE issue. I had one other user report this when diffing from Subversion (which is also a modal diff).  I installed KDE on my Ubuntu box, but I can't reproduce this so far.  If you think of any other special condition, please let me know.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2410
  • Hero Points: 135
Re: Problems with Perforce client
« Reply #16 on: May 06, 2013, 03:45:46 pm »
On a side note, I probably would have had this info sooner, but when attempting to use the file backup history to clean out extraneous debug statements I had added, the diff view was unusable.  The cursor is constantly flickering, whether trying to edit text or click the window buttons.  Not sure if someone has already mentioned this behavior yet or not.

I thought this was a KDE issue. I had one other user report this when diffing from Subversion (which is also a modal diff).  I installed KDE on my Ubuntu box, but I can't reproduce this so far.  If you think of any other special condition, please let me know.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2410
  • Hero Points: 135
Re: Problems with Perforce client
« Reply #17 on: May 06, 2013, 03:45:59 pm »
Quote
On a side note, I probably would have had this info sooner, but when attempting to use the file backup history to clean out extraneous debug statements I had added, the diff view was unusable.  The cursor is constantly flickering, whether trying to edit text or click the window buttons.  Not sure if someone has already mentioned this behavior yet or not.

I thought this was a KDE issue. I had one other user report this when diffing from Subversion (which is also a modal diff).  I installed KDE on my Ubuntu box, but I can't reproduce this so far.  If you think of any other special condition, please let me know.

shadm

  • Community Member
  • Posts: 49
  • Hero Points: 0
Re: Problems with Perforce client
« Reply #18 on: May 06, 2013, 04:15:24 pm »
I don't know of any special configuration I might have, except I use synergy to share my keyboard and mouse between this machine and my Windows workstation.  I have the Linux box configured as the server, so the keyboard and mouse are connected directly to my Linux workstation, which is where this is happening.

I would add that, in some additional testing, the flickering is not 100% reproducible, though I would say it's close.  One potential clue might be that if I cycle to another window or desktop (i.e. another Linux desktop, not the windows machine) and then go back to the diff window, usually the flickering has gone away.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2410
  • Hero Points: 135
Re: Problems with Perforce client
« Reply #19 on: May 06, 2013, 04:16:58 pm »
I was eventually able to reproduce this, but I'm not sure why it is doing it or what is causing it yet.