Author Topic: Slick using 100% of cpu  (Read 2870 times)

jporkkahtc

  • Senior Community Member
  • Posts: 1220
  • Hero Points: 89
  • Text
Slick using 100% of cpu
« on: May 03, 2013, 05:52:17 pm »
64bit, Beta 2, Win64.
I noticed that Slick has got 1 cpu core 100% busy.
Slick is still responsive.
When I close slick and start it again the busyness resumes.
Closing the workspace stops the busy, and reloading the workspace resumes the busy.

I only noticed because my laptop fan was running more than usual. It's terrible having so many cores that you never notice when you have a single threaded CPU hog anymore :-)

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Slick using 100% of cpu
« Reply #1 on: May 03, 2013, 06:45:19 pm »
Sounds to me like your workspace tag file is never getting finished. So it restarts when the workspace is again opened, never completes while workspace is open, lather-rinse-repeat.

We'll want to see if there is some code file in your workspace that may be tripping up the tagging parser. Use the Project > Retag workspace... menu command, and in the dialog that comes up, deselect the "Retag files in background" and "Retag modified files only" checkboxes so that you can see the progress control in the foreground. If that retagging gets hung up somewhere, let us know.

You may want to go into the Tools > Options under Editing > Context Tagging, and turn off the "Update workspace tag file on open" setting temporarily so you can run the above foreground tagging.
« Last Edit: May 03, 2013, 06:47:06 pm by Matthew »

jporkkahtc

  • Senior Community Member
  • Posts: 1220
  • Hero Points: 89
  • Text
Re: Slick using 100% of cpu
« Reply #2 on: May 03, 2013, 07:22:40 pm »
OK, I rebuilt all my tagfiles this way -- foreground and all files -- retagging finished without a problem.
CPU continues to be busy.
Background tagging of open files.
Use background thread when possible.
Update workspace on open
Update workspace on activate.
Then I closed the workspace and observed CPU usage go to zero.
When I opened the workspace again the CPU stays busy.

Recycling the VS.exe process doesn't help either.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2091
  • Hero Points: 259
Re: Slick using 100% of cpu
« Reply #3 on: May 06, 2013, 12:52:16 pm »
If the CPU appears to be busy, try turning on Slick-C profiling for a while and then turning it off, that should give us an indication of where SlickEdit is spending the time.

Also, do you have Symbol Coloring turned on?

magerbak

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Slick using 100% of cpu
« Reply #4 on: September 30, 2013, 01:59:49 pm »
I also have a similar problem on multiple projects (v18.0.0.13 32-bit with hotfix_se1800_5).

Tried retagging in the foreground (completed), shutdown VS and restarted, CPU for VS process is pegged at 50% (one of two cores). Other times I have seen it consuming over 90%.

The Slick-C profiling screen shot is attached.

I have background tagging on open and activate disabled. Right now this is 100% reproducible on two different projects and makes working with VS almost unusable.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2091
  • Hero Points: 259
Re: Slick using 100% of cpu
« Reply #5 on: October 02, 2013, 12:45:09 pm »
@magerbak:  Your problem is on account of makefile targets.  I'm guessing you added all the files under your source directory, including makefiles to your project.  Now SlickEdit is trying to do something with that.  You can either remove the makefiles from your project, or set the macro variables "def_show_makefile_target_menu" to 2 (Macros > Set Variable...)