Author Topic: B4: X11 autoraise on Linux64  (Read 4232 times)

DanEngholm

  • Community Member
  • Posts: 8
  • Hero Points: 0
B4: X11 autoraise on Linux64
« on: May 22, 2013, 11:30:21 pm »
I just installed Beta 4 (thanks for the invite).  It took a while for me to get my fonts and vertical line back, since those settings didn't get brought forward from v17, but that's a one-time thing and I can live with it.  What is going to absolutely drive me nuts is whenever I run my mouse over SlickEdit, the window autoraises.  I have X (via Gnome) configured to not do this with any application but somehow SlickEdit is overriding that behavior and doing it anyway.  I couldn't find any configuration option to make it stop.  Any ideas?

--Dan

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4035
  • Hero Points: 269
Re: B4: X11 autoraise on Linux64
« Reply #1 on: May 23, 2013, 01:53:52 am »
Please post more specifics on exactly what Linux OS you are using and how to configure it to reproduce your problem. Thanks

DanEngholm

  • Community Member
  • Posts: 8
  • Hero Points: 0
Re: B4: X11 autoraise on Linux64
« Reply #2 on: May 23, 2013, 06:11:17 pm »
This is Ubuntu 12.04 LTS, logged in using gnome-shell, instead of the default Unity UI.  To get this, install the base system as usual then install the gnome-shell package.  When logging in, click the little circular icon next to your name then choose Gnome, then log in as usual.

$ uname -a
Linux <hostname> 3.2.0-43-generic #68-Ubuntu SMP Wed May 15 03:33:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1100
  • Hero Points: 94
Re: B4: X11 autoraise on Linux64
« Reply #3 on: May 24, 2013, 02:14:12 pm »
Not able to reproduce this yet, going to need more info. This is what I am running:
$ uname -a
Linux ubuntu12-x64-template 3.2.0-44-generic #69-Ubuntu SMP Thu May 16 17:35:01 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ gnome-shell --version
GNOME Shell 3.4.1

In the Configuration Editor, under org.gnome.desktop.wm.preferences, auto-raise is disabled, and focus-mode is set to 'click'.  Are there any other options you have enabled that are non-default?

Is there a particular area that you passing the mouse over that is causing this (editor pane, tool window, menu/toolbar)?  What emulation are you running?  Could you export your SlickEdit options and post them?  Also may need a look at at the restore info from your configuration directory (vrestore.slk) to get an idea of your window layout.

DanEngholm

  • Community Member
  • Posts: 8
  • Hero Points: 0
Re: B4: X11 autoraise on Linux64
« Reply #4 on: May 24, 2013, 06:09:51 pm »
I'm running the same version of gnome-shell.

When I went to look in Configuration Editor to see if my settings matched yours, I couldn't find anything called "auto-raise" so I searched for "autoraise" and found two instances: /apps/compiz-1/plugins/core/screen0/options/autoraise and /apps/compizconfig-1/profiles/unity/plugins/core/screen0/options/autoraise.  They were both checked so I deselected them and the problem went away.  I reenabled both and SlickEdit doesn't autoraise.  autoraise_delay is 1000 but SE autoraised immediately whenever I passed over the main window, even when I had the new project dialog up (that was really annoying).

As I've been going through this stuff again, I realized that I'm not using compiz for my window manager.  Rather, I've switched it to metacity.  I have that set to not auto_raise and with focus_mode set to sloppy.

I realize that all of this Gnome shell stuff is highly confusing now.  It certainly confuses me.  It's seeming like this is some sort of Metacity vs. Compiz settings conflict which I can no longer reproduce.  Do you still want that other info?


Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1100
  • Hero Points: 94
Re: B4: X11 autoraise on Linux64
« Reply #5 on: May 24, 2013, 06:28:18 pm »
Sorry, the settings I reported were in dconf Editor, not Configuration Editor.  If you are satisified that problem is solved, then I won't have to spelunk through the Qt source looking for the problem.

DanEngholm

  • Community Member
  • Posts: 8
  • Hero Points: 0
Re: B4: X11 autoraise on Linux64
« Reply #6 on: May 24, 2013, 06:50:10 pm »
I spoke too soon.  I had left the two Compiz autoraise settings enabled and SE started autoraising again.  Now I can't get it to stop doing it, even though I now have them disabled.  It's only the main window that appears to do it; the Find and Replace and Reference windows don't autoraise when I pass the mouse over them nor do they cause the main application window to raise until I click on them.  When the New dialog is up, no autoraising happens on the main or New window.

I'm running SE with CUA emulation.  Options and vrestore.slk are attached.

org.gnome.desktop.wm.preferences.auto-raise is disable and focus-mode is sloppy.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1100
  • Hero Points: 94
Re: B4: X11 autoraise on Linux64
« Reply #7 on: May 24, 2013, 07:26:31 pm »
How about /apps/metacity/general/auto_raise setting?  Though I do not get the behavior you are describing with it enabled.

DanEngholm

  • Community Member
  • Posts: 8
  • Hero Points: 0
Re: B4: X11 autoraise on Linux64
« Reply #8 on: May 24, 2013, 09:31:45 pm »
/apps/metacity/general/auto_raise is disabled.  If I enable it, windows other than SE raise after the configured 1000ms of delay but SE still raises immediately.

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1100
  • Hero Points: 94
Re: B4: X11 autoraise on Linux64
« Reply #9 on: May 28, 2013, 04:17:49 pm »
The good news is I was able to reproduce this at least once.  The bad news is I haven't been able to reproduce it since, so I still need to track down the how and why.  I'll keep you posted.

pmsteinm

  • Community Member
  • Posts: 78
  • Hero Points: 0
Re: B4: X11 autoraise on Linux64
« Reply #10 on: July 22, 2013, 10:09:00 pm »
I've noticed this behavior on V18 which I just installed.  Whenever I mouse over the Vs window it autoraises.  This does not happen with versions 16  and 17.

I'm using fvwm-2.6.5 on SUSE Linux 10.4 (x86_64).  My window manger is configured so the only way to raise a window is via keyboard shortcut or clicking on the titlebar.

pmsteinm

  • Community Member
  • Posts: 78
  • Hero Points: 0
Re: B4: X11 autoraise on Linux64
« Reply #11 on: August 13, 2013, 04:52:47 pm »
This is fixed with 18.0.1.