Archived Read Only Forums > SlickEdit 2013 v18 beta

B4: X11 autoraise on Linux64

<< < (2/3) > >>

Lee:
Sorry, the settings I reported were in dconf Editor, not Configuration Editor.  If you are satisified that problem is solved, then I won't have to spelunk through the Qt source looking for the problem.

DanEngholm:
I spoke too soon.  I had left the two Compiz autoraise settings enabled and SE started autoraising again.  Now I can't get it to stop doing it, even though I now have them disabled.  It's only the main window that appears to do it; the Find and Replace and Reference windows don't autoraise when I pass the mouse over them nor do they cause the main application window to raise until I click on them.  When the New dialog is up, no autoraising happens on the main or New window.

I'm running SE with CUA emulation.  Options and vrestore.slk are attached.

org.gnome.desktop.wm.preferences.auto-raise is disable and focus-mode is sloppy.

Lee:
How about /apps/metacity/general/auto_raise setting?  Though I do not get the behavior you are describing with it enabled.

DanEngholm:
/apps/metacity/general/auto_raise is disabled.  If I enable it, windows other than SE raise after the configured 1000ms of delay but SE still raises immediately.

Lee:
The good news is I was able to reproduce this at least once.  The bad news is I haven't been able to reproduce it since, so I still need to track down the how and why.  I'll keep you posted.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version