Author Topic: Beta 6 - Mercurial Slick-C Error  (Read 1079 times)

astromme

  • Community Member
  • Posts: 89
  • Hero Points: 0
Beta 6 - Mercurial Slick-C Error
« on: June 03, 2013, 09:18:04 pm »
Trying to use Mercurial, if I right click in a file and select Version Control->History for <myfile>, I get a Slick-C Error:

Invalid argument
file=Hg.ex offset=5679

with the dump:

 Invalid argument
Hg.ex 5679 se.vc.Hg.localRootPath(
   1:   ._typename()=se.vc.Hg
   1:   .m-debug=0
   1:   .m-captionTable[0]=&Commit
   1:   .m-captionTable[1]=&Lock
   1:   .m-captionTable[2]=&Diff
   1:   .m-captionTable[3]=&History
   1:   .m-captionTable[4]=&Merge
   1:   .m-captionTable[5]=&Revert
   1:   .m-captionTable[6]=&Update
   1:   .m-captionTable[7]=&Add
   1:   .m-captionTable[8]=Remove
   1:   .m-captionTable[9]=Clone
   1:   .m-captionTable[10]=Browse repository
   1:   .m-captionTable[11]=Push to repository
   1:   .m-captionTable[12]=Pull from repository
   1:   .m-version=
   1:   .m-didDeferredInit=1
   p_window_id: 323
   p_object: OI_EDITOR
   p_name:
Hg.ex 3777 se.vc.Hg.getFileStatus(
   1:   ._typename()=se.vc.Hg
   1:   .m-debug=0
   1:   .m-captionTable[0]=&Commit
   1:   .m-captionTable[1]=&Lock
   1:   .m-captionTable[2]=&Diff
   1:   .m-captionTable[3]=&History
   1:   .m-captionTable[4]=&Merge
   1:   .m-captionTable[5]=&Revert
   1:   .m-captionTable[6]=&Update
   1:   .m-captionTable[7]=&Add
   1:   .m-captionTable[8]=Remove
   1:   .m-captionTable[9]=Clone
   1:   .m-captionTable[10]=Browse repository
   1:   .m-captionTable[11]=Push to repository
   1:   .m-captionTable[12]=Pull from repository
   1:   .m-version=
   1:   .m-didDeferredInit=1
   2:   <myfile>
   3:   6290
   4:   0
   p_window_id: 323
   p_object: OI_EDITOR
   p_name:
svc.ex 4713 svc_history(<myfile>,0,523,0)   p_window_id: 323   p_object: OI_EDITOR   p_name:


I'm on .10 now, but this happened with .8 as well.

- Andy

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2220
  • Hero Points: 118
Re: Beta 6 - Mercurial Slick-C Error
« Reply #1 on: June 04, 2013, 12:43:34 pm »
I will be looking at this.  What platform are you on?

Can you run this with def_svc_logging set to 1, and send me the output in <config>/18.0.0/logs/svc.log?
« Last Edit: June 04, 2013, 01:12:18 pm by Dan »