Author Topic: Beta 6: SE over RDP problems  (Read 2746 times)

asandler

  • Senior Community Member
  • Posts: 255
  • Hero Points: 22
Beta 6: SE over RDP problems
« on: June 04, 2013, 11:00:48 am »
I often work over RDP (Remote Desktop) connection. There are two problems that I consistently see with SE b6.

1. SE's dialog boxes don't respect "Font smoothing" settings of the RDP session. I.e. when I connect with "font smoothing" enabled in RDP settings, it would still disable anti-aliasing for SE fonts inside of dialog boxes. This problem also exists in SE17.

2. SE hogs RDP connection. RDP connection works fine as long as SE minimized or closed. Once I open SE, RDP connection gradually slows down. It starts with short hick-ups which grow in length until remote computer stops responding completely. Then I have to close the connection (often kill) and start a new one. This problem is new to SE18.

I'll appreciate if you address these two problems.

Regards,
Alex.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3839
  • Hero Points: 251
Re: Beta 6: SE over RDP problems
« Reply #1 on: June 04, 2013, 12:40:46 pm »
Hmm...I work through RDP all the time (using it now). I definitely don't see a degradation in performance when I work for many hours. The only problem I had for years was a really bad internet connection which I'm happy to say has been fixed by TW cable recently running 200 feet of new cable from the street to my house.

Phil Barila

  • Senior Community Member
  • Posts: 746
  • Hero Points: 61
Re: Beta 6: SE over RDP problems
« Reply #2 on: June 04, 2013, 12:54:44 pm »
I've seen this issue twice, with earlier betas, but it was due to something causing SE to be busy constantly repainting, and I don't know what that was.  (I am so sorry not to be able to give you a repro!)  When I could get Process Explorer to the foreground, it showed SE using one core flat out.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3839
  • Hero Points: 251
Re: Beta 6: SE over RDP problems
« Reply #3 on: June 04, 2013, 12:57:21 pm »
Maybe it's this problem:

http://community.slickedit.com/index.php/topic,9066.0.html

I don't have a reproducible test case yet but I'm still working on it.

asandler

  • Senior Community Member
  • Posts: 255
  • Hero Points: 22
Re: Beta 6: SE over RDP problems
« Reply #4 on: June 04, 2013, 02:27:05 pm »
@Clark: 1. I'll try disabling scrollbars.
2. Do you have font smoothing enabled?

jamiew

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Beta 6: SE over RDP problems
« Reply #5 on: June 04, 2013, 02:30:43 pm »
+1

When using RDP from my Mac to my Windows 7 instance after I compile out of SE it'll cause my RDP process to run away with my Mac's (the client) processor.  I have to kill SE to regain control again.  If I kill RDP and remote back in without killing SE it'll immediately consume my processor again.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3839
  • Hero Points: 251
Re: Beta 6: SE over RDP problems
« Reply #6 on: June 04, 2013, 02:32:22 pm »
@Clark: 1. I'll try disabling scrollbars.
2. Do you have font smoothing enabled?

font smoothing is enabled by default but you can turn it off. Hard to know exactly what Qt is doing though but the option definitely has a noticeable effect.

asandler

  • Senior Community Member
  • Posts: 255
  • Hero Points: 22
Re: Beta 6: SE over RDP problems
« Reply #7 on: June 04, 2013, 02:47:15 pm »
Hmm.. I actually do something special. In RDP's settings dialog, experience tab, I disable everything except font smoothing. May-be this is what causes the problem.

jamiew

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Beta 6: SE over RDP problems
« Reply #8 on: June 07, 2013, 11:57:40 am »
FWIW, I'm still running into this problem without font smoothing enabled.  I was hoping this would resolve my issue but unfortunately I'm still seeing it.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3839
  • Hero Points: 251
Re: Beta 6: SE over RDP problems
« Reply #9 on: June 07, 2013, 01:02:51 pm »
What I'm seeing with RDP for fonts is the opposite of what your seeing. SlickEdit is always using anti-aliasing regardless of the settings in RDP. If I turn off anti-aliasing in SlickEdit, then I can get rid of the anti-aliasing. Other application use anti-aliasing based on the RDP smoothing setting.

I'm connecting from a Windows 7 machine to a Windows 7 machine.

jamiew

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Beta 6: SE over RDP problems
« Reply #10 on: June 07, 2013, 02:39:16 pm »
If I turn off anti-aliasing in SE (with font smooth disabled in RDP) the frequency of the problem is considerably worse.

I am connecting from MacOs to Windows 7 using Microsoft's Remote Desktop Connection app.

asandler

  • Senior Community Member
  • Posts: 255
  • Hero Points: 22
Re: Beta 6: SE over RDP problems
« Reply #11 on: June 07, 2013, 03:08:01 pm »
1. Indeed, hogging problem disappears if I disable scrollbars.
2. Anti-aliasing doesn't work in dialogs. It does work well in the editor window. Oh and you need to reopen SE from remote session to see the problem. Try setting only "font smoothing" in the experience tab. Then connect, close SE, open it and there you should have it.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3839
  • Hero Points: 251
Re: Beta 6: SE over RDP problems
« Reply #12 on: June 07, 2013, 06:06:54 pm »
I tried setting only "Font smoothing" on but I still see normal anti-aliasing.

asandler

  • Senior Community Member
  • Posts: 255
  • Hero Points: 22
Re: Beta 6: SE over RDP problems
« Reply #13 on: June 08, 2013, 11:28:15 am »
Did you try restarting SE when connected remotely?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3839
  • Hero Points: 251
Re: Beta 6: SE over RDP problems
« Reply #14 on: June 08, 2013, 01:09:56 pm »
Yes, I restarted SlickEdit