Author Topic: Strange soft wrap behavior with vim emulation  (Read 1832 times)

Wanderer

  • Senior Community Member
  • Posts: 557
  • Hero Points: 23
Strange soft wrap behavior with vim emulation
« on: June 09, 2013, 02:25:53 pm »
SlickEdit 2013 (v18.0.0.10 64-bit)
License type: Beta License
Build Date: May 30, 2013
Emulation: Vim
OS: Windows 7 x64  OS Version: 6.01.7601  Service Pack 1
Project Type: No project open
Language: .cmd (Batch)

When editing a .cmd file:
- View->[uncheck Soft Wrap]
- Press 'Esc' to enter normal mode
- Soft Wrap returns.
- View -> [uncheck Soft Wrap]
- press 'o' to open a new line.
- Soft Wrap returns.

Have not tried this in non-Vim emulation.

UPDATE:
Tools->Options->Languages->All Languages:
When I unchecked "Enable soft wrap", the problem appears to have gone away.
Whether that is checked or not, I expect to  be able to turn Soft Wrap on or off as desired, on a per-buffer basis. 
« Last Edit: June 09, 2013, 02:29:49 pm by Wanderer »

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Strange soft wrap behavior with vim emulation
« Reply #1 on: June 09, 2013, 03:46:08 pm »
Thanks for the report.  I reproduced it in a .cpp file, so it is most likely a global problem.  I see incorrect behavior even if I turn that option off under 'All Languages' (similar to what you described), so I'm not sure if it has to do with that option or not, but I'll look into it and let you know when it's fixed.

- Ryan

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Strange soft wrap behavior with vim emulation
« Reply #2 on: June 09, 2013, 11:04:47 pm »
This will be fixed in the next build.  Thanks for your help.

- Ryan