Archived Read Only Forums > SlickEdit 2013 v18 beta

B7 tab colour settings broken

(1/3) > >>

dunkers:
I use Tools | Colors | Application to change the document tab settings. I see the following problems:

Changing the selected colors (background and/or foreground) has no effect.

Changing the unselected colors (background and/or foreground) affects the selected tab!

When the 'use system default color' option is ticked, the sample box shows a classic black on grey, but the unselected tab has a white background. The selected tab is some weird shade of blue and can't be change at all.

dunkers:
This is still broken in the SE 2013 release.

I think there is some confusion as well: I was under the impression that selected means the tab of the window you're currently working in, and unselected means the tabs of other windows. However, I see that there is an active setting, and that one alters the tab of the window you're working in. That makes sense: it is the active tab.

But... what is selected and unselected, then? Changing the unselected setting appears to do nothing, and changing the selected setting affects the tab of the windows you're not working in (i.e. what I would call the unselected tab).

Any chance of resolving this, or at least explaining what they mean?

Ryan:
Here's how it looks to me when these apply.  Hopefully this helps and doesn't confuse you further :-\.  I think these are all working right, but they are just a little confusing.


* Active - The tab of the current document you are in which has focus.
* Selected - The tab of the current document when that editor window does not have focus.
* Unselected - The tabs of the non-current documents...which of course, do not have focus.
So you should see that the Active/Selected colors toggle if you click in the editor window (Active), and then click to another app (Selected), and then move back to the editor window (Active again).

Is this how it looks like it's working for you?

- Ryan

dunkers:
Ah! Now you've explained it it makes sense - I didn't realise the color would change when you selected a different app.

But... it doesn't work for me, still. On switching focus to something else, the active tab now uses the selected color so all tabs are the same. The unselected color is not used anywhere that I can see.

Rodney:
I'm starting to suspect your configured colors are borked. Try running with a clean config.

++rodney

Navigation

[0] Message Index

[#] Next page

Go to full version