Author Topic: Special Characters settings affects itself !  (Read 2046 times)

jporkkahtc

  • Senior Community Member
  • Posts: 1856
  • Hero Points: 179
  • Text
Special Characters settings affects itself !
« on: June 13, 2013, 09:27:37 pm »
In the non-unicode editor windows area:
Set "Other Ctrl Charcs" to 10.
The character displayed in the "Char" column is the character selected in the "Line feed" row.
Change the "Line Feed" character to 65, click "Apply" and the "Char" for both rows changes to "A".

That just seems wrong.

Setting the CR line to 10 and the LF line to 13 results in blanks being displayed, better than infinite recursion :-)

The "Unicode Editor Windows" settings is oh-so-much better.
Can we ditch the non-unicode settings entirely?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4938
  • Hero Points: 404
Re: Special Characters settings affects itself !
« Reply #1 on: June 13, 2013, 10:35:25 pm »
In the non-unicode editor windows area:
Set "Other Ctrl Charcs" to 10.
The character displayed in the "Char" column is the character selected in the "Line feed" row.
Change the "Line Feed" character to 65, click "Apply" and the "Char" for both rows changes to "A".
I must not be following your steps correctly. When I make these changes I don't see anything unexpected happen. When I set Set "Other Ctrl Chars" to 10, a blank is displayed for the "Char". That is what is supposed to happen. After I change the line feed to 65, blank is still displayed for "Other Ctrl Chars" both in the dialog and in source files.
 Am I doing something wrong?

Setting the CR line to 10 and the LF line to 13 results in blanks being displayed, better than infinite recursion :-)
That is supposed to happen. 10 and 13 characters are not displayable characters so they are replaced with a space character.

If you configure SlickEdit to load your source files as Utf-8, you can ignore the non-unicode window settings. I wouldn't recommend doing this now. SlickEdit needs better Unicode/proportional font support first. This new special characters display is another step towards better Unicode/proportional font support.

jporkkahtc

  • Senior Community Member
  • Posts: 1856
  • Hero Points: 179
  • Text
Re: Special Characters settings affects itself !
« Reply #2 on: June 13, 2013, 11:09:36 pm »
Are you hitting "Apply"? (Or make the changes, OK, and then start options again?)
Was this fixed in B8? I'm using B7.
See the attached .doc.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4938
  • Hero Points: 404
Re: Special Characters settings affects itself !
« Reply #3 on: June 13, 2013, 11:36:49 pm »
Reproduced. Hmm...not sure how I missed it. Displays correctly in Document tab edit windows but not in the dialog edit window.