Author Topic: Perforce access error  (Read 1492 times)

chip.dip

  • Community Member
  • Posts: 18
  • Hero Points: 1
Perforce access error
« on: June 28, 2013, 12:45:55 am »
I am using 64bit SE v18 and 64bit Perforce.
When I try using any Perforce access function, I get the following error:
"Could not get current version for file '<filename>'     Unicode clients require a Unicode enabled server"

My files are not Unicode, they are normal text.

What am I doing wrong?


Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2390
  • Hero Points: 133
Re: Perforce access error
« Reply #1 on: June 28, 2013, 12:01:27 pm »
I'm not sure.  What happens if you run "p4 print <filename>" in a console window?

Are you sure you have the right version of p4.exe specified?  I'm wondering if you could have an old version in your PATH.

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: Perforce access error
« Reply #2 on: June 28, 2013, 04:20:41 pm »

chip.dip

  • Community Member
  • Posts: 18
  • Hero Points: 1
Re: Perforce access error
« Reply #3 on: June 28, 2013, 07:19:25 pm »
setting P4CHARSET to none in my perforce client did the trick.