Author Topic: SECore 3.7.1 Breakpoints  (Read 3568 times)

brebey

  • Community Member
  • Posts: 58
  • Hero Points: 2
SECore 3.7.1 Breakpoints
« on: July 11, 2013, 03:31:53 pm »
I'm using FlashBuilder 4.7 (built on Eclipse 3.7) with SECore 3.7.1. 
Breakpoints can't be set if SECore is the editor in use. Keyboard toggling doesn't work, clicking on the margin doesn't work, and selecting "Toggle xxx Breakpoint" from the Run menu doesn't work.  I can find no way to set breakpoints when SECore is in use.

I see some discussion from long ago (multiple years) on this topic, then it seems to have dried up.

Is there any fix for this?  Any workarounds?

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SECore 3.7.1 Breakpoints
« Reply #1 on: July 12, 2013, 02:10:51 pm »
Unfortunately with 3rd party Eclipse plugins that provide debuggers, setting breakpoints from within our editor often doesn't work out of the box :(.  They implement their own types of debuggers, which recognize only their own types of breakpoints, and we are required to make sure that for their IDE we are setting the correct type of breakpoint.  This is one of the reasons why we have produced plugins which depend on the CDT/JDT/etc.

The first thing to look into is seeing if our most recent Flex support plugin, which I posted here a while back: http://community.slickedit.com/index.php/topic,5622.0.html , will work for this.  I'm not sure, but it is worth a try to see if you can get it installed and working in your environment, and then see if breakpoints can be set as described.

The Eclipse plugin installation mechanism has changed since we produced this plugin, so I believe you will need to extract it to the ECLIPSEDIR/dropins/ directory (create 'dropins' if it doesn't exist) instead of the ECLIPSEDIR/plugins/ directory as noted in the instructions.

Thanks,

Ryan