Author Topic: The # key on a Mac.  (Read 1047 times)

mrfish

  • Junior Community Member
  • Posts: 7
  • Hero Points: 0
The # key on a Mac.
« on: July 23, 2013, 01:09:10 pm »
I'm using SE 2012 on an iMac and I have the keyboard emulation set to brief.

However, the issue is I cannot generate the # symbol, usually it is alt 3 on a Mac keyboard, but that doesn't work in SlickEdit.

This is a regular wired Apple Keyboard with number pad.

Any help appreciated as I have a code snippet to do it at the moment.

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: The # key on a Mac.
« Reply #1 on: July 23, 2013, 03:51:44 pm »
Hi,

For some bizzare reason alt-3 is already bound to something on Mac, and you need to remove this bind for the default # key to reappear.

Goto:

Tools/Options...

and select the options for
Keyboard & Mouse / Key Bindings

Search by key sequence and enter alt-3 and remove the binding to the default command (can't recall which as I already removed it on my setup!)



Does anyone know a way to automate that with a script by the way?


Cheers,
Mark


mrfish

  • Junior Community Member
  • Posts: 7
  • Hero Points: 0
Re: The # key on a Mac.
« Reply #2 on: July 23, 2013, 04:59:10 pm »
Thank you very much.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: The # key on a Mac.
« Reply #3 on: July 23, 2013, 09:54:33 pm »
Just FYI: Alt keys, depending on the emulation that is chosen, are quite often bound to one of the "bookmark" commands. Most Alt+ bindings are turned off in the Mac-centric "Mac OS X" and "Xcode" emulations. But they can still hang around if you've upgraded from a previous version's config.

ExtremeXS

  • Senior Community Member
  • Posts: 108
  • Hero Points: 6
Re: The # key on a Mac.
« Reply #4 on: July 24, 2013, 12:18:44 am »
Hey Matthew,

The alt-3 binding comes back everytime I update (importing my current config) to any new version even if I've removed the binding previously.

I've also changed all the bookmark bindings which always behave, but this setting persistently resets to it's default when upgrading.

Cheers,
Mark