Author Topic: Error: Null characters ignored  (Read 4775 times)

vinay.melgiri@gmail.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Error: Null characters ignored
« on: September 05, 2013, 03:52:25 pm »
I am using slickedit for long time now. i edited a file and saved it. And tried to compile. it gives me error " Error: Null characters ignored".

I edited the file in vim editor and compiled. it works fine there.
can anyone help me on this???

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: Error: Null characters ignored
« Reply #1 on: September 05, 2013, 05:54:03 pm »
Some more information might help someone respond:

What OS is this on?  And what version of the OS?
What version of SlickEdit is this on?
Where is the file, is it on a network share?  If so, what type of network share (e.g. Samba, Windows, etc).

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Error: Null characters ignored
« Reply #2 on: September 05, 2013, 06:58:56 pm »
It would also be helpful to take a peek at the "known good" vim-edited file (in SlickEdit), and show Hex view, just to make sure something strange isn't going on with the file encoding. Switch back to normal text view, do some edits in SlickEdit, save the file, and then re-examine the hex display.

If you're seeing strange sequences show up, then this could be a case of file encoding confusion. The easiest way to clean that up is to open the file again (in SE) and explicitly select the proper encoding. Once you've selected an explicit encoding, SE will remember what you've chosen and use that every time that specific file is opened.

vinay.melgiri@gmail.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Error: Null characters ignored
« Reply #3 on: September 06, 2013, 02:23:58 pm »
Slickedit runs on Windows 7, 64 bit version.
I tried both versions of Slickedit 17.0.2 and 18.0.1
File is in linux system (ubuntu) on samba(version 3.4.7) share i guess.

This is what happens:
I open a "good" vim edited file in slickedit.
switched to 'line hex' view
declare a variable and save it.
no change in hex view as of this stage.
i close and reopen the file again.
now i see the first line of file is being replaced by random characters.
I have attached the pic.

Regarding file encoding setting, i have kept it as auto unicode.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Error: Null characters ignored
« Reply #4 on: September 06, 2013, 02:51:52 pm »
Thanks for the update. A couple questions, so we can try to reproduce this problem.

1. If you copy this file locally and open it, does the same problem arise? Or is it just when opened via the remote share?

2. Are you opening the file using a UNC path (\\server\share\file.txt), or has this Samba share been mapped as a Windows drive letter?

3. How are you opening the file? Are you using the File>Open dialog, picking from the recent file menu, entering "edit <path>" on the SE command line, etc.

vinay.melgiri@gmail.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Error: Null characters ignored
« Reply #5 on: September 06, 2013, 04:15:03 pm »
1. this does not happen when done locally.
2. it has been mapped as a windows drive.
3. I open the file using slickedit button 'open a file for editing'.

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: Error: Null characters ignored
« Reply #6 on: September 06, 2013, 10:46:43 pm »
Sounds like this topic.

As a temporary workaround, invoking SlickEdit with the -s3 invocation option might help.

vinay.melgiri@gmail.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Error: Null characters ignored
« Reply #7 on: September 07, 2013, 04:23:51 pm »
Excellent!!!
Thank you very much chrisant.
problem solved.

Mike

  • SlickEdit Team Member
  • Community Member
  • *
  • Posts: 99
  • Hero Points: 20
Re: Error: Null characters ignored
« Reply #8 on: December 18, 2013, 07:13:28 pm »
You can set an environment variable which will invoke the aforementioned attribute when a new instance is started:
VSLICK=-s3