Author Topic: MinGW64 Installation and use on SlickEdit  (Read 2750 times)

Mike H

  • Community Member
  • Posts: 26
  • Hero Points: 3
MinGW64 Installation and use on SlickEdit
« on: March 03, 2014, 05:21:42 pm »
I've used SE many times in the past and have been an avid user.  I recently tried using it at my newest company and can't seem to get the GNU C++ integration working.  This is what I most use it for so I may have to switch to a product like Code::blocks (which worked right away!) if we can't get this working.

Can someone please provide to me (and possibly others), the steps to install MinGW64 and integrate with SE?
please include:
  • Where to download MinGW64 from (seems like there are multiple places and its confusing), what version, where to place it on my local machine.
  • Once the sample "Hello World" project is created, what GNU C options need to be set
  • What include directories should be entered for proper tagging of C++
  • Debugger setup

The goal is that once these steps are followed, I can do a full build, launch the debugger with a breakpoint at main, and have SE's GUI debugger fully working (breakpoints, watch, local variables, etc., etc.)


  • New Community Member
  • Posts: 1
  • Hero Points: 0
MinGW64 Installation and use on SlickEdit
« Reply #1 on: March 04, 2016, 07:39:13 pm »
This is another CreateProcess: file not found-gcc-error-question. According to the -v switch it cant open cc1plus. Things I tried:
-> add C:binmingwlibexecgccmingw324.8.1 to path my mingw inst-path is C:binmingw
-> add C:binmingwbin to path
-> copy cc1plus.exe to bin, the same directory as gcc
-> create junction from C:mingw to C:binmingw just in case...
I use Windows 7

But the error still persists. Yesterday I installed mingw on windows xp, it worked just fine
Am I missing something?