Author Topic: Compiler-specific tag files can't add c++ headers without Ext. name  (Read 1485 times)

china_sundasheng

  • Community Member
  • Posts: 18
  • Hero Points: 0
In context Tagging dialog, I can't add any c++ header (such as iostream etc.) of mingw althougth using wildcard * or selecting anyone manually. It seems that se ignores such files. Is there something wrong?
win vista
se v18.0.1
mingw

mjdl

  • Senior Community Member
  • Posts: 145
  • Hero Points: 17
  • SE 24.0.10 x64 Windows 10 x64 v1909
Re: Compiler-specific tag files can't add c++ headers without Ext. name
« Reply #1 on: March 11, 2014, 05:51:35 pm »
You need to read about how SE 18 handles extensionless files. In the epic PDF manual, that starts on p. 439; in the program's help file, search for "Managing Extensionless Files".

Go to Options-->Languages-->Extensionless File Manager to fiddle around with it. There all the extensionless file names can be added and their language specified. When you retag your include files (e.g. through the "Auto tag" dialog), they will now be included in the scanning.

I'm attaching an SE options group export just of "Extensionless File Manager" of my configuration which includes just those files found in the MinGW and Microsoft 2012 C/C++ compilers. You can import it in your SE configuration (but please back it up before importing!).
« Last Edit: March 11, 2014, 05:58:25 pm by mjdl »

china_sundasheng

  • Community Member
  • Posts: 18
  • Hero Points: 0
Re: Compiler-specific tag files can't add c++ headers without Ext. name
« Reply #2 on: March 12, 2014, 12:13:11 am »
Thanks very much. I never pay attention to this function >:(
Now I will learn it :)