Author Topic: Core for Kepler : Betas now available  (Read 5369 times)

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Core for Kepler : Betas now available
« Reply #15 on: May 07, 2014, 02:16:50 pm »
The Ubuntu machine that we built the beta on was using glibc 2.15. We were having issues building on Ubuntu with an earlier gcc (and on CentOS 4.9, which is what our desktop products are normally built on).
We'll working this week on getting the build working with a glibc between v2.5 and v2.12

gchouini

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #16 on: May 07, 2014, 02:53:04 pm »
Thank you, most appreciated.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Core for Kepler : Betas now available
« Reply #17 on: May 15, 2014, 07:41:25 pm »
Just wanted to update you that we have today posted an update to the beta. This update addresses the glibc version issue for the Linux platforms that do not have glibc 2.12 or later available.
The download is available at the same URL as before:  https://customer.slickedit.com/update/secore/kepler_beta

gchouini

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #18 on: May 16, 2014, 09:15:57 pm »
thank you, the latest beta appears to be working on Centos 6.5

gchouini

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #19 on: May 21, 2014, 02:45:16 pm »
The slickedit search/replace function is not work.  The Find and Replace dialog box has each of the tabs (Find, Find in Files, Replace, Replace in Files), but the box is empty. 

The trace has:
com.slickedit.core: Menu command: javaMenu_handler com.slickedit.core.commands.AddBookmark
com.slickedit.core: Menu command: javaMenu_handler com.slickedit.core.commands.RemoveBookmark
com.slickedit.core: Menu command: javaMenu_handler com.slickedit.core.commands.AddTask
com.slickedit.core: Menu command: javaMenu_handler com.slickedit.core.commands.RemoveTask
com.slickedit.core: Menu command: javaMenu_handler nothing

Mightymuke

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #20 on: May 26, 2014, 10:19:28 pm »
I have a fairly old version of the beta but it wont update (says its already up to date). If I remove it and try to resinstall it I'm getting the error:

Code: [Select]
Error
Tue May 27 09:58:06 NZST 2014
Error reading signed content.

java.io.IOException: The file "C:\Marcus\Tools\eclipse_kepler_cpp_64\plugins\com.slickedit.core_4.3.0" does not exist
at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleFile.<init>(ZipBundleFile.java:60)
at org.eclipse.osgi.baseadaptor.bundlefile.ZipBundleFile.<init>(ZipBundleFile.java:54)
at org.eclipse.osgi.internal.signedcontent.SignedBundleHook.getSignedContent(SignedBundleHook.java:253)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.checkCertificates(CertificateChecker.java:73)
at org.eclipse.equinox.internal.p2.engine.phases.CertificateChecker.start(CertificateChecker.java:54)
at org.eclipse.equinox.internal.p2.engine.phases.CheckTrust.completePhase(CheckTrust.java:50)
at org.eclipse.equinox.internal.p2.engine.Phase.postPerform(Phase.java:251)
at org.eclipse.equinox.internal.p2.engine.Phase.perform(Phase.java:101)
at org.eclipse.equinox.internal.p2.engine.PhaseSet.perform(PhaseSet.java:47)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:75)
at org.eclipse.equinox.internal.p2.engine.Engine.perform(Engine.java:44)
at org.eclipse.equinox.p2.operations.ProvisioningSession.performProvisioningPlan(ProvisioningSession.java:174)
at org.eclipse.equinox.p2.operations.ProfileModificationJob.runModal(ProfileModificationJob.java:79)
at org.eclipse.equinox.p2.operations.ProvisioningJob.run(ProvisioningJob.java:177)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Core for Kepler : Betas now available
« Reply #21 on: May 29, 2014, 03:12:36 pm »
@gchouini: Thanks for lettings us know about this one. We've got some work to do to fix up the menus with the API & resource changes in Eclipse 4.x. (We're also seeing a related problem with duplicate menu entries)

@Mightymuke: I'm assuming from your later bug report postings (May 28th) that you were able to get the newer version. Let me know if that's not the case.


Mightymuke

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #22 on: May 29, 2014, 06:52:41 pm »
Nope, that's not the case. The bug report postings were from another instance of Eclipse that I'm running that still has the original version of the beta.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Core for Kepler : Betas now available
« Reply #23 on: May 30, 2014, 01:43:48 pm »
Are you able to re-create your Eclipse binary directory easily? When I do testing on a Linux VM I usually just nuke the whole install and re-extract the tar.gz, but keeping all my workspaces. But I understand if this is not feasible for you if you have other plugins that you need.
You may have to manually root out whatever installed or cached downloads of the SlickEdit binaries are under your eclipse install, forcing the new versions to be fetched.

Mightymuke

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #24 on: May 30, 2014, 07:36:38 pm »
We use a lot of different plugins so I'm trying to avoid a complete reinstall (plus this will be for our entire team of developers). I've also found any files and folders containing SlickEdit in the name and have removed them, that's when I started getting the error mentioned. I'm presuming there may have been something I missed, any ideas what?

Mightymuke

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #25 on: June 03, 2014, 07:10:12 pm »
I was told that that this is where I must go for support for the plugin, but I don't seem to be getting any here. Is there anywhere else I can log a report? I have a team of developers using this product, and the lack of support I'm getting is starting to impact their work. We've been very patient waiting for this long overdue release, but we're about ready to cut our losses and look for an alternative solution.

Mike

  • SlickEdit Team Member
  • Community Member
  • *
  • Posts: 86
  • Hero Points: 19
Re: Core for Kepler : Betas now available
« Reply #26 on: June 04, 2014, 06:33:39 pm »
As far as getting the latest release, I think you just needed to remove all com.slickedit.* directories from [EclipseInstallDir]/plugins and then you can download the latest version as usual.

Even though it may seem your posts have not been attended to, we do appreciate your feedback and our development team is aware of the concerns you have expressed. I have asked our developers and management to take a closer look at the threads on this board, especially those which have not gotten a reply.

Thanks for your assistance during the beta cycle!
« Last Edit: June 04, 2014, 06:48:30 pm by Mike »

Mightymuke

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #27 on: June 10, 2014, 02:00:03 am »
That didn't work. I eventually got the updated beta installed by reinstalling everything again from scratch.

Mightymuke

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Core for Kepler : Betas now available
« Reply #28 on: June 10, 2014, 02:40:00 am »
Just tried updating a colleagues instance and it failed with the same error:

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Error reading signed content.
The file "D:\Development\Applications\eclipse-cpp-kepler-SR2-win32\plugins\com.slickedit.core_4.3.0" does not exist


After a bit of trial and error I've found how to successfully update it. Manually delete anything in your Eclipse installation that has slickedit in the filename (a bunch of folders in "features", a bunch of folders in "plugins", and a file in "configuration/org.eclipse.osgi/manifests"). Start Eclipse and uninstall SlickEdit. This will restart Eclipse - when its back up reinstall SlickEdit.

There seems to be a couple of issues here - first the update doesn't work. I presume this is because the version number isn't changing (just the build date). Second, the uninstall doesn't clean up properly, it leaves a bunch of SlickEdit files lying around. If you try to simply uninstall then reinstall, the reinstall seems to fail (it wont update some of the files), then anything I did from this point seemed to generate the error above.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Core for Kepler : Betas now available
« Reply #29 on: June 10, 2014, 01:41:53 pm »
Glad you were able to get the latest after some trial and error. We've been loathe to change the version number during the beta releases since we want the release version to match the version of Eclipse we're targeting. But it seems we'll need to abandon this in order to allow for these incremental updates during betas. (Our hope had been that the differences in the signature hashes in the root of the update site would take care of signaling that the binaries are different, but it looks like the version number check trumps this).