Author Topic: perl code  (Read 2143 times)

mxu

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
perl code
« on: May 01, 2014, 03:16:44 pm »
hi,

just got SlickEdit 2013 installed on Window 7, but the editor doesn't recognize *.pl files, the opened files look like pure text files, no color contrast for comments, variable, string and subroutine, 

how can I make *.pl editor work ?


thanks

mxu

hs2

  • Senior Community Member
  • Posts: 2754
  • Hero Points: 291
Re: perl code
« Reply #1 on: May 01, 2014, 04:35:36 pm »
Although pl files are mapped to 'Perl' document by default verify your 'pl' extension assingment in 'Tools > Options > Languages > File Extension Manager'.
HS2

mxu

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: perl code
« Reply #2 on: May 01, 2014, 05:20:22 pm »
HS2,
'Tools > Options > Languages > File Extension Manager' was set to associate *.pl to Perl at my setting, but *.pl opened like pure ascii file.

mxu


hs2

  • Senior Community Member
  • Posts: 2754
  • Hero Points: 291
Re: perl code
« Reply #3 on: May 02, 2014, 07:36:24 am »
Strange.. Is it just this particular pl file where the document mode is wrong ? In this case try to fix the doc. mode manually with 'Document>Select Mode'.
HS2