Recent Posts

Pages: 1 ... 8 9 [10]
91
SlickEdit® / How to get Python autocomplete?
« Last post by JimmieC on April 25, 2024, 09:47:18 PM »
I have started messing with Python a little bit. In SE I can run the debugger.
However, the autocomplete does not always work. It works for "os". But, it does not work for the variable (string?).
Visual Studio Code autocomplete works but SE does not. What do I need to configure?
I have attached some screen shots.
92
SlickEdit® / Re: v27 and v28 editing areas slow down
« Last post by iccpicc on April 25, 2024, 07:08:09 AM »
I don't use git, all my code is on local disk, are there any options that might affect this? Such as time Settings.
93
SlickEdit® / Re: v27 and v28 editing areas slow down
« Last post by Dan on April 25, 2024, 02:07:41 AM »
If you're using Git, you could make sure Live Diff is off. But I don't notice it slowing things down and still use the editor every day.
94
SlickEdit® / v27 and v28 editing areas slow down
« Last post by iccpicc on April 25, 2024, 01:30:41 AM »
I used the v26 version of the editing area to run smoothly, with the mouse scroll can respond immediately;
The v27 v28 version also responds smoothly when the file is first opened, but after a few minutes, the response will become slow and stuttering, and the mouse will not be able to move immediately after scrolling.
But if you reload the file again, the reload_with_encoding command gets faster again, for some reason;
I also checked that the Settings for option--File Options--Load are the same as in V26, but they are not resolved.
95
SlickEdit® / Re: Command line search/replace wrap behaving differently
« Last post by Clark on April 25, 2024, 12:17:13 AM »
Your fix fails sometimes. I can't always get it to fail but sometimes it fails. I get it to fail more often when I use the mouse but I know I got it to fail once using the keyboard.

I figured that since we are already prompting in the message line, might as well keep prompting in the message line. I could add an option to get_event() to avoid bailing when focus changes but that would take a new installer.

96
SlickEdit® / Re: Command line search/replace wrap behaving differently
« Last post by Dennis on April 24, 2024, 11:07:41 PM »
Tried out the hot fix.  Don't really like the command line prompting instead of the message box.  I have a somewhat simpler fix.  Patch attached.
97
SlickEdit® / Re: Command line search/replace wrap behaving differently
« Last post by Dennis on April 24, 2024, 08:24:07 PM »
That...was...FAST!
98
SlickEdit® / Re: Command line search/replace wrap behaving differently
« Last post by Clark on April 24, 2024, 08:23:07 PM »
Fixed typo
99
SlickEdit® / Re: Command line search/replace wrap behaving differently
« Last post by Dennis on April 24, 2024, 08:20:25 PM »
Thanks.  BTW, the hotfix page has a small typo (28.0.0.2).
100
SlickEdit® / Re: Command line search/replace wrap behaving differently
« Last post by Clark on April 24, 2024, 02:13:09 PM »
This has been broken for many years

A hot fix is available for this.

Download the hot fix here:

https://www.slickedit.com/hotfixes

Then load the hot fix: Help>Product Updates>Load Hot Fix...
Pages: 1 ... 8 9 [10]