Recent Posts

Pages: 1 2 3 [4] 5 6 ... 10
31
SlickEdit® / Re: Linux vsdiff not working
« Last post by Clark on April 06, 2021, 03:09:41 am »
The negative line numbers issue will be fixed for 25.0.2 (fix already checked in). We are looking into the matching to see what is going on there.

We have plans for improving the line length issue. I'll post here when when that happens.
32
SlickEdit® / Re: Linux vsdiff not working
« Last post by StephenW on April 06, 2021, 02:42:03 am »
There is no rush for any fix for me as I also own a copy of bcompare (https://www.scootersoftware.com) that works on Linux and does diff the files correctly.  But it is much easier to do diffs using SlickEdit's builtin diff, so I prefer to use that normally.  I think I may write a macro to run bcompare from SlickEdit if I have to do it often.
33
SlickEdit® / Re: Missing references in a push-ref in a .c file
« Last post by Dennis on April 06, 2021, 12:32:17 am »
This one was not hot-fixable, but will be fixed in 25.0.2 (time frame still undetermined).
34
I just tried it and I observe the same as you. For the 3rd parameter I see same as you, but my code has evolved since that time so I can't find where the original came from to give you for reproduction.

When I reported this I had hotfix 2, but now I have hotfix 6. Something must have been fixed between hotfixes 2 and 6 to fix this.
35
I tried the example and used your user.cfg.xml.  All the test cases worked fine, except for the third one, where it indeed did not list &FLASHmutexHandle, however, that symbol was not defined in the source file.  Maybe there was an additional header file you intended to include?

I did stumble upon a couple minor bugs, in ANSI-C mode, we shouldn't be offering "nullptr" or "new CLASS" as completion options.  I will add fixes for that to the 25.0.1 hot fix.
36
SlickEdit® / Re: Linux vsdiff not working
« Last post by Clark on April 05, 2021, 06:30:54 pm »
The negative line numbers are a bug. This will be fixed in 25.0.2. This wacky line number shouldn't effect anything else other than it's wrong and looks really bad.

Not sure why line 87 isn't picked up as a match "('len(blk[2]=4066',)". We will look into this. Either this is a bug or it is due to the algorithm bailing due to the massive number of mismatches. Under extreme conditions (very large files with many differences), the diff algorithm will bail which results in non-optimal diff output. This is done so the diff doesn't take as long. The only way we will know is to investigate this further.
37
SlickEdit® / external formatter
« Last post by mzel on April 05, 2021, 06:05:50 pm »
How can I setup VS to reformat(beautify) the code in the text tab using an external formatter e.g. .exe or a Python script?
38
SlickEdit® / Re: Linux vsdiff not working
« Last post by StephenW on April 05, 2021, 05:13:03 pm »
Take a look at line 86 in both files.  That is the last matching line that vsdiff shows at the top of the files.  But if you then look at the files individually rather than in vsdiff, line 87 also matches.  But vsdiff does not see that match, and in the bad.log display it is matched to line 1335613 of good.log but given a line number of -2629 instead of 87.  There are no colour marks in the column between the two file panes for the matches from there on to the bottom of the files.  The Next Diff button does find them despite that.

The negative line numbers shown at the bottom of bad.log are not a good sign - maybe that is what is causing some of the problems.
39
SlickEdit® / Re: SlickEdit Ubuntu x64
« Last post by regionalchamps on April 05, 2021, 04:39:22 pm »
Done.
40
SlickEdit® / Re: SlickEdit Ubuntu x64
« Last post by SlickEdit Support on April 05, 2021, 02:30:55 pm »
It looks like you are trying to run SlickEdit on a Linux box with a Mac license.

Can you PM us a copy of your license file?

Thanks,
SlickEdit Support

Pages: 1 2 3 [4] 5 6 ... 10