SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => Topic started by: dmain on January 31, 2020, 12:51:53 am

Title: No more references.
Post by: dmain on January 31, 2020, 12:51:53 am
When I attempt to ctrl/ I get a popup box that says No more references. The References window populates momentarily and then clears with the exception of the open file name which is followed by NO REFERENCES. There is an older post from 2008 on this subject and I have followed all of the recommendations in that post. It has been working intermittently since. I am running v24.0.0.8 with the most recent hot fixes applied.
Title: Re: No more references.
Post by: Dennis on January 31, 2020, 01:02:40 am
Verify that "Look in:" on the References tool window is set to what you want, likely <Current Workspace>.

Also, verify that "Show all" is checked on the References tool window.

You can also try rebuilding your workspace tag file (Project > Retag Workspace...).

Otherwise, you should *at a minimum* see the reference in the current file which you originated the reference search from, if that is not happening, you should post the source file, perhaps there is a context tagging issue specific to that file or the specific language.

References can also be broken if you change the identifier characters in your language-specific color coding settings in an incorrect manner, so if you have modified color coding, you might want to double-check that also.
Title: Re: No more references.
Post by: dmain on January 31, 2020, 01:17:07 am
Dennis, Thanks for the quick response.

I have tried multiple selections for "Look in:" Most recently I had this set for "All Tag Files" "Current Workspace" does not work either.

"Show all" is checked.

I have already re-tagged the workspace many times.

If I ctrl/ a symbol in a file that contains many instances of the symbol non of the other symbols in the file are found. When I clear the popup box the references window goes completely empty.

Per the other thread I renamed my config directory and started SE from scratch. I went through the menus and selected very generic settings. I did not select anything custom with respect to color coding.

One thing to note is that the files that I am editing are on a network drive and my workspace/project/tag files are all on my local drive.
Title: Re: No more references.
Post by: Dennis on January 31, 2020, 03:02:40 pm
Can you post one sample file (and show which item you were trying to get references to)?

Also, is there any aliasing involved with the network files?  That is symbolic links, assigning drive letters, any way that the same files could be being referenced as two distinct paths?
Title: Re: No more references.
Post by: dmain on January 31, 2020, 06:19:10 pm
Dennis,
I am unable to post any of our source code due to company policy. There is really nothing complex or unique about our source code itself.

I am accessing the code on a Windows 10 machine using a mapped drive to a samba server. There is only one mapped drive that provides a path to this code.

I have been accessing our code this way for several years now. I was having intermittent issues with SE being extremely sluggish. At that time I was using V18. I recently upgraded to V24 in an attempt to solve the sluggishness. V24 fixed the issue. Unfortunately it also caused this new issue.

So in the last week I have removed all instances of SE from my machine, installed V24, removed the config directory and allowed SE to generate a new one, created a new workspace/project, retagged the workspace.

Like I said Cntrl/ was working a few times along the way using V24. Cntrl. is working now.

Are there any other recommendations that you can make without seeing my source code?
Title: Re: No more references.
Post by: Dennis on January 31, 2020, 06:31:50 pm
Try it with one of the sample workspaces shipped with SlickEdit.
Title: Re: No more references.
Post by: dmain on January 31, 2020, 08:29:45 pm
I opened the cpp workspace. When I cntrl/ to the method member function it says symbol 'method' not found. This is different than what I get in my project "No more references." pop up window, but it still failed to work as expected.

It then gives me the option to search instead and that finds all occurrences of method().
Title: Re: No more references.
Post by: dmain on January 31, 2020, 08:38:49 pm
I made a copy of my code on the local machine, created a workspace and project for the code, added the tree and re-tagged the project. cntrl/ still does not work. It starts by popping a box that asks which instance of the function name I would like to find the references for. Once selected it pops the "No more references." box.
Title: Re: No more references.
Post by: dmain on January 31, 2020, 08:45:45 pm
I tried to reference the same symbol again, but this time I placed my cursor in the Symbol: dropdown box and hit return. It popped the same box asking for an instance selection. After selecting it popped the "No more references." box and when I closed it it populated the results window with two copies of all of the references to the selected function. Both instances of the fine name were followed by "NO REFERENCES", but the references were listed properly after each instance of the file name. i.e. twice.
Title: Re: No more references.
Post by: Dennis on February 03, 2020, 03:07:19 pm
Could you post your user.cfg.xml from your configuration directory?

Also could you try the sample workspace in a completely clean configuration?  Start the editor from the shell and point it to an entirely new directory for the configuration directory:

       
Code: [Select]
  vs +new -sc /tmp/newconfig
Title: Re: No more references.
Post by: dmain on February 04, 2020, 09:36:07 pm
Attached please find the xml file that you requested.
Title: Re: No more references.
Post by: xotrox on February 05, 2020, 08:28:14 am
Maybe it is not the most elegant workaround but to deal with No Reference  I do: in options changed referencing strategy from background to the last one. Then when I look for something I have files with No references shown in Reference view. Theuly do not disappear. Then I go to file and then search using ctrl+f.
Title: Re: No more references.
Post by: Dennis on February 07, 2020, 06:57:17 pm
@dmain: 

Nothing harmful looking in your user.cfg.xml.  What was your results when you tried the sample project with a new configuration directory as I suggested?

What platform are you on?  What programming language are you primarily working in?
Title: Re: No more references.
Post by: dmain on February 07, 2020, 08:44:24 pm
With a new configuration directory and using the sample project ctrl/ worked. Then I generated a new workspace/project for my source on the network drive and ctrl/ is still working. I hope that it does not stop working again but for now I have what I need. It sure would be nice to know what went wrong in the first place. I never experience this problem with V18 which I had been using for a couple of years.

Windows 10
C/C++ other is what I select when I create a project.
Title: Re: No more references.
Post by: dmain on February 25, 2020, 07:58:35 pm
Well unfortunately my issue came back yesterday. I had some company mandated OS/Security upgrades and I believe the issue returning was coincident with the associated system reboot.
Title: Re: No more references.
Post by: dmain on March 31, 2020, 09:48:14 pm
Dennis,

Do you have any recommendations as to how to make the feature work indefinitely?

Dale
Title: Re: No more references.
Post by: Dennis on April 01, 2020, 02:41:29 pm
24.0.2 will be coming out in the near future.  It might help.

Without some examples and a reproducible test case, there is not much more I can do here.

One last setting you could check:  Documents > C/C++ Options > Context Tagging > Attempt to filter out ...., do you have this option checked?

Also, you can also go back to the sample C/C++ project and do a references test when this happens.  If it fails in the sample project, then you have something reproducible that you can send in  to support (along with a copy of your configuration directory).
Title: Re: No more references.
Post by: dmain on April 01, 2020, 07:12:33 pm
Dennis,

Can we work on this issue some more. As I said it stopped working again. I really need a permanent fix for this issue.

Dale
Title: Re: No more references.
Post by: dmain on April 01, 2020, 07:25:19 pm
I do not have Attempt to filter out... checked.

The sample project symbol browsing does not work either. It is also poping the same "No more references" box.

I have attached my config file.
Title: Re: No more references.
Post by: SlickEdit Support on April 17, 2020, 02:16:28 pm
Message sent via SlickEdit Support.
Title: Re: No more references.
Post by: pineapple on July 14, 2020, 03:50:15 am
This problem has been around since January? Aaaargh. Just started installing 24.0.2 with Hotfix 14. Using Brief emulation. This feature is one of the most heavily used for me so it is extremely frustrating to have it not work.

One observation I can add that I didn't see mentioned.  I use the right click pulldown menu to access the feature.  I need to retry Go to Reference usually 3 times, sometimes 4 before it works.
Title: Re: No more references.
Post by: Dennis on July 14, 2020, 02:42:48 pm
Always hard to fix problems you can't reproduce.

Maybe the magic ingredient can be found in your user.cfg.xml, could you post that?

Also, exactly which tool windows do you have visible and/or docked.
Title: Re: No more references.
Post by: SlickEdit Support on July 15, 2020, 03:29:28 pm
Hey pineapple,

Do you or your corporate IT folks have any anti-malware tools like Crowdstrike or Endpoint Agent installed on your machine? Or any other heavy-handed security tools?

SlickEdit Support
Title: Re: No more references.
Post by: SlickEdit Support on July 15, 2020, 06:23:48 pm
Pineapple,

We just sent you a PM.

SlickEdit Support

Title: Re: No more references.
Post by: pineapple on July 20, 2020, 09:05:05 pm
SlickEdit Support sent me a preview of a new hotfix to try and hey!  It fixes the "No more references" problem.  Or at least as far as I could tell.

I was getting the problem about half the time I selected "Go to reference..".  The failure was bursty, disappearing at times making me think the problem had gone away, then boom.  I had to click 4 times to get a list of references.  After installing the hotfix, I haven't seen the problem once.  Even did extra reference searches for the heck of it.  No failures.  So what was it?  Pointer to a random variable?

Really appreciate the fix.  Thanks guys (and gals).
Title: Re: No more references.
Post by: Dennis on July 21, 2020, 02:52:44 pm
There was a software timeout that as not being reset correctly.