Recent Posts

Pages: [1] 2 3 ... 10
1
SlickEdit® / Re: whitespace not allowed in execute selection?
« Last post by Clark on Today at 04:07:52 am »
What command are you executing? I tried adding leading space for a couple different commands and they both worked.
2
SlickEdit® / whitespace not allowed in execute selection?
« Last post by pbrightly on May 17, 2021, 11:53:19 pm »
Is there any reason whitespace should not be allowed in execute_selection()?  I tend to keep all my notes using Slick, and I frequently keep some handy commands in my notes, allowing me to simply press Alt-= on any line to execute it.
I also like to format my text by levels of indentation using tabs and/or spaces.  Unfortunately, that causes execute_selection() to fail with a bad return code.  Easy fix, I just put strip() around the string and reloaded the module.  Should that be official? Or is there some reason not to do that?

PS. When I modify one of Slicks modules rather than my own, how is that effected on my next update?  Does it get overwritten?
3
Hello,
If you go into project properties...
And then top right configurations...
And then choose the configuration you want and press the set active button at the bottom right.
Cheerio
4
General Programming / debugging swift application on macos
« Last post by moatingodseye on May 16, 2021, 08:44:00 am »
Hello,
I've just installed the slickedit 2020 trial onto macos catalina. Created a simple swift application (Basically hello world) and run it. Fine works, but no matter what i do i can't get the debugger to stop... step into.. nope runs the entire program. Step to cursor, nope ignores the cursor. I see the red box indicating breakpoint appear but never stops.
This is brand spanking new installation, all i did was install slickedit, create a swift project, and press run. SlickEdit nicely said oops no compiler tools installed. I let it do that and now runs but won't debug.
Help!
Thanks
5
SlickEdit® / Re: libc++ tagging problem
« Last post by rjpontefract on May 16, 2021, 08:29:20 am »
Thanks Dennis, that certainly helped.  I'm still unsure as to why template parameters are shown as not found, even in the location that they are declared.  There must be some logic to this that I'm missing.

An update to the MacOS defines would be appreciated as having tags available certainly helps when exploring a code base.
6
SlickEdit® / Re: libc++ tagging problem
« Last post by Dennis on May 15, 2021, 02:01:16 pm »
You may need to add that #define _LIBCPP_BOOL_CONSTANT() to your C/C++ Preprocessing.  Document > C/C++ Options > C/C++ Preprocessing.

I'll take a closer look at this, and see if I can update the pre-defined C/C++ defines on macOS next week.
7
SlickEdit® / libc++ tagging problem
« Last post by rjpontefract on May 15, 2021, 09:25:15 am »
Hi, I'm running SE 25.0.1(hot fix 6) on macOS 11.3 and I was wandering around a C++ codebase and I ended up following symbols into the standard library.  I then ended up trying to find where true_type and false_type were defined but they were coloured as "symbol not found". 

Some searching later and I found them in type_traits and I'm trying to figure out why the tagging engine didn't also find them. 

Is there someway I can get SE to tag them correctly.  They are defined as shown in the attached screen capture.  I have _LIBCPP_STD_VER defined as 20 to include C++ 20 features.  Why does the tagging engine see them as "not found" and why does it not like the template parameters?  Is there something I need to define to make this work?  Any pointers would be appreciated.
8
SlickEdit® / Re: Emoji highlighting error
« Last post by Clark on May 15, 2021, 03:08:35 am »
Here's some sample text with a composite sequence:

Ax̂C

Copy the above text and paste into an XML or other unicode file on Windows. SlickEdit for macOS and Linux will treat the above as 4 unicode characters when you cursor left and right. Windows SlickEdit will treat the above sequence as 3 sets of characters.

Note that this forum does not display the above text correctly for me on Windows. The hat should be displayed above the 'x'.
9
SlickEdit® / Re: Emoji highlighting error
« Last post by Clark on May 15, 2021, 02:08:12 am »
This is not a font rendering issue. CharNextW is used to traverse composite characters. Composite characters consist of multiple Unicode characters. SlickEdit checks in many places that composite characters, which are multiple unicode characters, are not bisected (selection doesn't bisect a composite character sequence). I tested some composite sequences in Notepad and it seems to traverse them correctly. They must be using something different than CharNextW or working around it's bugs.
10
SlickEdit® / Re: Emoji highlighting error
« Last post by jporkkahtc on May 15, 2021, 01:50:16 am »
Curious, because I tried in Outlook and even notepad - seems to work OK.
I would assume that at least Notepad would use the basic font rendering stuff in Windows.

Interesting ... In Outlook, 🌵 is green, but in Word and Notepad it is gray.
Pages: [1] 2 3 ... 10