Recent Posts

Pages: 1 ... 8 9 [10]
91
SlickEdit® / Python error with network drive.
« Last post by link on July 20, 2022, 02:42:27 am »
I have an odd error when I open a Python file that starts with a '#!/usr/bin/python3' on a network mapped drive using sshfs-win:

Code: [Select]
Bad return code from /usr/bin/python3: -2024 See Output window for details.
The output window spams the same line every few seconds (during which time SE is unresponsive):
Code: [Select]
EXEC /usr/bin/python3 --version
I'm using SlickEdit v26.0.3.1 64-bit for Windows.  It stops spamming the error and freezing once I close the file.  If I open the same file copied to the local C: drive, there's no problem.  There's also no problem if the file starts with: '#!/usr/bin/python', but if I change it to e.g. '#!/usr/bin/env python', it starts trying to run /usr/bin/env --version instead.  Very strange.  Any idea what is causing this and how to stop it?
92
SlickEdit® / Re: FiF Advanced
« Last post by Clark on July 20, 2022, 01:16:41 am »
I'm not able to reproduce this foreground search issue so far. I tested maximum file size first. Then I tested specifying a date range. Not sure what magic is needed here.
93
SlickEdit® / Re: FiF and ZipExtension
« Last post by Clark on July 20, 2022, 01:05:52 am »
Reproduced the first bug. For the second bug, do you mean a search using the "Files tab"?
94
SlickEdit® / FiF Advanced
« Last post by jporkkahtc on July 19, 2022, 10:53:56 pm »
FiF Advanced filtering doesn't work with Foreground Search.
The advanced filter seems to just be ignored in this case.
95
SlickEdit® / FiF and ZipExtension
« Last post by jporkkahtc on July 19, 2022, 10:44:25 pm »
Add a new extension (NUPKG) to Tools > Options > File Options > Open: Zip Extensions.
Copy a *.ZIP file to *.NUPKG

Attempt to find something from a file inside the zip.

BUG: Slick should find this in both the *ZIP and *NUPKG file, but it only finds it in the ZIP.
In FiF change to ForegroundSearch.
Now it works.

FiF: Directories has the same problem, but doesn't seem to have a workaround.
For some reason Directories search doesn't have a Foreground option.
96
SlickEdit® / Re: SE 26 hang when finding references
« Last post by rjpontefract on July 19, 2022, 10:40:41 pm »
A little more information that I've found regarding this issue.  I have narrowed it down to a single tag file, if I disable that tag file then find references works as expected.  If I enable that tag file I get the hang.

I can't find any reference to the symbol that causes issues in that tag file and rebuilding that tag file made no difference to the behaviour.
97
SlickEdit® / Re: SE 26 hang when finding references
« Last post by rjpontefract on July 19, 2022, 09:44:44 pm »
Hi Dennis

It seem that I can now recreate this on demand.  There is one symbol that causes this hang every time.  The only thing I can find that is different about it is that the name is used for both a struct and a static function in the same file, something like this:

Code: [Select]
#include <stdio.h>

typedef struct ref_test
{
    int a;
    int b[3];
    unsigned char c[1];
} Tref_test;

static void ref_test(int a, int b, int c)
{
  fprintf(stderr,"%d %d %d\n",a,b,c);
}

int main(int argc, char **argv)
{
  ref_test(1,2,3);
}

The hang is caused when I put the cursor on the call to ref_test(1,2,3) in main and hit ctrl-/.  A dialog is presented with the 2 symbol definitions.  If I choose the function definition symbol it works as expected.  If I choose the struct symbol then I get the hang.

However, it doesn't do it with the simple example above, just in the main code base where both the struct and the function are used in many places.

Hope that helps.

98
SlickEdit® / Re: SE 26 hang when finding references
« Last post by rjpontefract on July 19, 2022, 09:07:32 pm »
Hi Dennis

I just had another hang looking for references and I tried both Ctrl-Alt-Shift-F2 and Ctrl-Alt-Shift-F9 and neither command did anything.  The VS UI is greyed out and Windows is showing the blue circle mouse cursor.
99
SlickEdit® / Re: SE 26 hang when finding references
« Last post by Dennis on July 19, 2022, 06:06:33 pm »
When SlickEdit hangs on references, can you interrupt it with the Slick-C interrupt key sequence?

From help:

Interrupting Slick-C Macros
A long-running Slick-C macro can be interrupted by holding down the following key sequences:

Ctrl+Alt+Shift+F2 (Ctrl+Option+Command+S on macOS) -- Halt Slick-C® macro that is executing. Use this to terminate infinite loops.

Ctrl+Alt+Shift+F9 (Ctrl+Option+Command+S on macOS) -- Halt Slick-C® macro that is executing, even if it is currently executing a background timer event. Note that halting the interpreter in a timer event can frequently leave SlickEdit in an unusable state which will require closing and restarting the editor.

If that does work, you will get a Slick-C stack error (this is to be expected, you interrupted a running function).  The trace (or possibly multiple traces) will be written to %SLICKEDITCONFIG%/logs/stack.log.

The Visual Studio stack trace was of no use, since the symbol information is not complete or correct unless I get a mini dump file so I can map the symbol locations back to the original build.  There are two types of Visual Studio crash dumps, one that is minimal (mini dump), which does not include variables or global memory, really it is just the stack trace.  And then there is the large dump file that includes everything.  I would not expect there to be any strings in a mini-dump that would be proprietary to you.

Mini Dumps vs Full Crash Dumps (from Microsoft)
When Windows captures a crash dump it can capture either a mini or full crash dump.

Mini dumps include just the essentials — registers, stack segment and stack trace.
Full crash dumps also include the data segments and can be enormous (as in multiple gigabyte enormous) but are handy if you need to know what was in memory when the crash happened.
100
SlickEdit® / Re: Symbol scroll
« Last post by dunkers on July 19, 2022, 04:01:50 pm »
I think I've grasped it now, thanks, and I see alt-wheelxx does indeed do what you describe. My ctrl-up/dn were set to prev/next-proc (I am a long time user of Slickedit so the setting no doubt just kept getting copied down the line). Changed now to -tag.

Thanks very much ;)
Pages: 1 ... 8 9 [10]