SlickEdit Community

Archived Read Only Forums => SlickEdit 2017 v22 Beta Discussion => Topic started by: jnairb on August 04, 2017, 08:42:35 pm

Title: search doesn't highlight found text
Post by: jnairb on August 04, 2017, 08:42:35 pm
If I use search-forward or search-backward, the found text is not highlighted. search-again still highlights subsequent hits. (Beta 1, Windows 7 x64)
Title: Re: search doesn't highlight found text
Post by: Clark on August 04, 2017, 11:53:35 pm
I tried a default Brief emulation config and search-forward or search-again don't select any text. If I turn the option to leave text selected (Tools>Options>Editing>Search>Leave selected), then both these command select the text that is found.

Not sure if there's another config difference or maybe I've misinterpreted what you mean by highlighted.
Title: Re: search doesn't highlight found text
Post by: jnairb on August 05, 2017, 03:49:28 am
I searched for an option that might control this, but didn't find anything. I don't have Leave selected turned on. The highlighting looks like selected text (it's highlighted with the selected text background), but it is not selected. The highlighting is only temporary -- after about 4 seconds it disappears. And if I press delete before the "highlight" goes away, only the first character of the found text is deleted instead of the entire highlighted text (as occurs if I turn Leave selected on).

Interestingly, if I turn Leave selected on, then for the first 4 seconds the found text appears with the selection background and white text. After 4 seconds it reverts to normal selected text color. With Leave selected off, it's highlighted like selected text and after 4 seconds reverts to normal text.

With VS 21, this highlighting occurs for both the first search (search-forward/backward) and repeated searches (search-again). With 22 beta1, the highlighting is only on search-again.
Title: Re: search doesn't highlight found text
Post by: Clark on August 05, 2017, 01:21:32 pm
Reproduced. I had color current line on which is the default for a plain text file. Once I turned that off, I reproduced it.  Thanks for the post. We will get this fixed.