Recent Posts

Pages: [1] 2 3 ... 10
SlickEdit® / SlickEdit consuming 100% CPU, doing nothing
« Last post by tim_k on Today at 07:45:52 pm »
I'm running, hotfix 6, but this started before I applied the hotfix.

If I have slickedit open, but no files or workspaces open, the CPU usage is <1%, as you'd expect. When I create a new blank file (still no workspace), CPU usage jumps to about 14%. If I open an existing VHDL file, CPU usage jumps to 80-100%, and the UI becomes very sluggish and unresponsive. If I open another VHDL file, the CPU usage pegs at 98-100%, and does not drop. Closing the files returns CPU usage to expected levels.

If I open SystemVerilog files, the CPU usage jumps to about 40%, and doesn't seem to increase with additional files opened.

With a workspace open the CPU usage is about the same, even allowing time for tagging etc to complete.

I just checked my linux box, and I'm also seeing similar behavior on RHEL7 with SE v, no hotfixes.

This is making SE virtually unusable. Any ideas?


SlickEdit® / Re: VS Crash
« Last post by patrick on Today at 03:51:54 pm »
Thanks, we got the files.
SlickEdit® / Re: VS Crash
« Last post by texasaggie97 on April 12, 2021, 04:29:55 pm »
I uploaded both the user.cfg.xml and a zip with the *.vpw, *,vpwhist and the *.vpj's.

One of the git repos pointed to by one of the vpj files is large. It is currently ~16GB in size in ~311k files with a mix of files: C/C++, C#, perl, python, LabVIEW files, documentation files, etc.
Features and/or Improvements / Re: Improve work over SFTP
« Last post by byates on April 10, 2021, 02:05:34 pm »
I agree. This is the only feature that keeps me from being able to use SE. We work on remote VMs in Azure. SSH access only through a jumphost. VSCode works perfectly this way.
SlickEdit® / Re: Java enum values not shown in autolist of an enum
« Last post by Dennis on April 09, 2021, 10:48:53 pm »
Reproduced.  Looks like our Java enum parsing is failing to get the enumerators in that class.  Will fix for 25.0.2.

Thanks again for your patience on these gray old bugs.
SlickEdit® / Re: C++ push-tag-filter-overloads bug when function NOT overloaded
« Last post by Dennis on April 09, 2021, 09:53:41 pm »
This bug will be fixed in the next iteration of the 25.0.1 hot fix (Revision 9).

Thanks for the detailed sample code and instructions, and thanks for your patience on this one.  Let me know if you have any problems with the fix when you get it.
SlickEdit® / Re: Help on Error Start Debugger
« Last post by slin on April 09, 2021, 08:46:08 pm »
Hi Dennis,
The problem was resolved after I restarted the machine. The logging becomes normal after that too. Thanks for you help!

I hit another other issues after that, which does not show in my old machine either.

1. When I press F5 (or F7), a window/tab with the name "Build(.process)" jumps out into the editor window. It shows the same content as Build tool window at the bottom.  How can I disable it?
2. The above one is a minor issue.  What really bother me is when I press F5, the gdb did not go to the breakpoints that I set. In stead, it seems running until I hit the pause button and then it goes to the breakpoint.
3. I also observed some stack_log complains, after which the tool windows at the left side was forced off.
I attached the logs and screen captures for the above issues.
Update: I installed 2019 version 2400, which has been used in my old machine.  I tried several times on the same workspace. I haven't seen any of the above problems yet. I will keep using 2400 right now.
SlickEdit® / Re: python f-string color coding problem with escaped braces
« Last post by Clark on April 09, 2021, 08:21:54 pm »
It's the same problem for all the f-string definitions. I fixed them all.
SlickEdit® / Re: Autosave untitled files leftovers
« Last post by Clark on April 09, 2021, 08:21:09 pm »
Good catch!

Untitled files (and autosave files) should be stored in an unversioned directory like backup history. Then this won't continue to happen. We will fix this for 25.0.2. We will need to make sure the old versioned "autosave" directory is not copied when 25.0.2 upgrades the config.
Pages: [1] 2 3 ... 10