Recent Posts

Pages: [1] 2 3 ... 10
1
So I just deleted my /config and started over with fresh, and was able to make it happen using the exact steps I described.

1) start with fresh config
2) In Tools/Options go to Languages/Web Authoring Languages/HTML/Formatting.
3) Edit the default profile
4) For indent, set the first three fields to 3, and check Indent with tabs.  Save settings/apply.

5) Now copy that code I posted to a new html file (which did seem to paste fine with tabs intact in my sample).

6) Put the cursor on the <tr> line, hit ESC and issue the "comment" command or use Document/Comment Lines.

The entire <tr> line is destroyed, and looks exactly as I posted before.
2
OK let me reset my SE environment to find the right settings to make it happen and I'll post again.

Just to be clear, though, I am using real tabs (not spaces) - so when I said "hopefully you will see the tr and td indented with two tabs at 3 spaces, I actually meant two "real" tabs that were just set to 3 spaces wide.
3
Yes the Perl one is the one I used currently !
Thanks
4
OK, that is good news - I look forward to trying the fix. Small correction - the resolution I tried was 1920x1080, not 1920x1024.
5
Please post a file attachment. I tried beautify with the settings you specify and I get 2 tabs with only 2 spaces and the problem doesn't reproduce. I even tried manually adding the extra space and no luck.

Also, what are the beautifier settings when you run the "comment" command. I wasn't sure I needed to change them after creating the sample file.
6
If I'm reading this right, looks like there are options for a bunch of different syntax. Do you just want ECMAScript? If so, I would think the Perl syntax would be pretty close.
7
I'm currently running a VMWare Ubuntu VM and it doesn't allow me to select 1920 by 1024 (I can get a bunch of others). I'm sure we have machines at the office where we can reproduce that.

While I'm not seeing a clipping bug, I am seen a very suspicious problem. If I have those files open, the Name column is significantly wider (too wide IMO). Once I close those files, then the Name field is right on. This definitely looks like a bug. In fact, when I open just one of them, then a bunch of extra padding is added to the Name column again. My guess is that if we fix that, we will also fix the clipping problem you are seeing.

Note: v21 doesn't not have this bug
8
I reported this about a year ago and was hoping since we are in the beta stages with 22 it might get fixed.   

Basically, the "comment" command will destroy HTML code by misplacing the start/end of comment characters.   It's a little tricky to reproduce so I'll try to post the same instructions.

It has to do with tab settings and HTML formatter settings.

With a fresh config, go to Document/HTML options/Formatting, then Edit the profile and set Indent, Org tab size and tab size to 3.   Also check Indent with tabs.

Create a new html file with the following:

Code: [Select]
<html lang="en">
<head>
<meta charset="UTF-8">
<title></title>
</head>
<body>
<div>
<table>
<tr>
<td></td>
</tr>
</table>
</div>
</body>
</html>

You can maybe try using the beautify command as I'm not sure how the forum post will copy over... hopefully then you will see the tr and td lines indented with two tabs at 3 spaces. Now issue the "comment" command on one or more of these lines.   I am seeing SE corrupt or destroy the beginning and/or end of the code on these lines when commenting.   I'll try posting the results of commenting all lines between the body tags here in a code block...

Code: [Select]
<html lang="en">
<head>
<meta charset="UTF-8">
<title></title>
</head>
<body>
<!--<div>-->
<!--<table>-->
<!-- <-->
<!-- <td></-->
<!-- </-->
<!--</table>-->
<!--</div>-->
</body>
</html>

I think in other experiments I used 4,3, and 2 space settings and they all corrupted the code too.

As you might imagine, this bug has caught me off guard many times where I've had to go back and repair the "uncommented" code.

Basically it just looks like SE is miscalculating the start/end of the code to insert the <!-- and --> sequences.

Since I work as a web app developer I really hope this one can get fixed...it's a really annoying one.

For the second bug, it's easy to reproduce (and still appears to be there):

  * Go to the last line of this HTML file and issue the command "slick-enter".  With the latest v22B2, I see the error "VSCFGP_BEAUTIFIER_FUNCALL_PARAM_ALIGN not valid".   Maybe this is not supposed to be a valid command for html files, but I tried with other file types and it doesn't happen.  Not a big priority; I think I had a macro file back then that triggered this problem so I just worked around it.   I am just mentioning it again.
9
Hi,
Is it possible to offer std::regex format support in "Regex Evaluator" tool ?
Thanks
10
The change in height after clicking 1 file also occurs in CentOS. But extension can still be seen. Only after opening both files does extension disappear.

But why is SE changing the height after clicking one of them? Maybe it is somehow related?
Pages: [1] 2 3 ... 10