Recent Posts

Pages: [1] 2 3 ... 10
1
SlickEdit® / Re: How do I use _mfgrepid=
« Last post by Graeme on Today at 02:32:04 am »
One way is like this  - add the line shown to the end of the toolShowFind function in tbfind.e

Code: [Select]
   formid.p_user2 = '';
   formid._findgrep.p_text = "<New>";   // <<<<<<<  add this line
   _macro('m', was_recording);
   return;

It might be possible to do it without modifying tbfind.e - something like this

      _control _findgrep;
      formid = activate_tool_window('_tbfind_form', true, '_findstring');
      formid._findgrep.p_text = "<New>";


2
SlickEdit® / How do I use _mfgrepid=
« Last post by timur on July 28, 2021, 11:12:38 pm »
I'm trying to modify the Find dialog box so that the "Search Results window" option always says "<New>".  It seems that tbfind.e has changed a lot since the last time I tried to do this, so I'm a bit lost new.

Specifically, I noticed that there seems to be a "_mfgrepid=" option that lets you specify GREP_NEW_WINDOW as the defaults "grep id".  Is this what I want, and if so, how do I set this option?

If _mfgrepid= is not what I want, then what should I do?  I tried modifying _init_grepbuffers(), but that didn't seem to work.

I'm using v23 on Linux.
3
Slick-C® Macro Programming / plugin questions
« Last post by Graeme on July 27, 2021, 05:41:16 am »
attached is a zip file plugin for xretrace.  When I create the plugin, I get some warnings "function should be declared in namespace "user_graeme" for all the _command type functions in xretrace_scrollbar.e.  If I try to put them in a namespace I get some new errors such as "class name must be camel case" etc.
i.e.
why does adding this line give new errors.
namespace user_graeme;

Second question, xretrace.e also has some _command type functions but the plugin builder doesn't give any errors for that file  - should it?  - or why does xretrace_scrollbar.e get namespace errors and not xretrace.e?

A comment on the plugin builder - for things like plugin-new and "add files" etc. a file explorer window comes up - but slick doesn't remember which folder I last browsed to  - and since I had the slick startup exe folder set to somewhere in "program files" I had to do quite a bit of explorer browsing.  I "fixed" this by setting the startup folder to be the configuration folder I was testing with.

The slick help should probably have a bit more information on how to use namespaces in slick C.





4
Features and/or Improvements / Re: References tool window improvements
« Last post by Graeme on July 24, 2021, 12:42:53 am »

You might be able to stop the preview window from jumping by setting def_tag_hover_preview to zero.  When you hover the mouse cursor over an entry in the references tree view, it makes the preview window show that entry.  Try setting it to zero using the "set macro variable" command in the macro menu - or the set-var command on the command line if you don't want the hovering behaviour.

There is also def_tag_hover_delay and def_tag_hover_editor_delay  - see the help.
The advantage of having the preview window show stuff from the refs window is that you save screen space if you have the refs toolwindow visible all the time.  See the "preview tool window" options in the settings dialog if you didn't already set it up.  It allows you to select which toolwindows affect the content of the preview window.
5
Features and/or Improvements / Re: References tool window improvements
« Last post by Dennis on July 23, 2021, 11:12:37 pm »
Thanks for the suggestions.
6
SlickEdit® / Re: is the plugin mechanism useable in 25.0.2
« Last post by Graeme on July 23, 2021, 10:17:31 pm »
Yes, I just zipped it.  I didn't know there was a plugin creator.  I'll give it a try.  Thanks.
7
SlickEdit® / Re: Attach to Virtual Machine not working
« Last post by patrick on July 23, 2021, 02:16:58 pm »
The fix for this will be in the next 25.0.2 hotfix. 
8
SlickEdit® / Re: is the plugin mechanism useable in 25.0.2
« Last post by Clark on July 23, 2021, 02:10:30 pm »
How did you create your plug-in? If you just zip up your files, you can’t rely on order of macro loading. You have to use the plug-in creation commands. If I remember correctly the manifest (written by plug-in creation commands) specifies the macro load order and is generated automatically.
9
SlickEdit® / Re: is the plugin mechanism useable in 25.0.2
« Last post by Graeme on July 23, 2021, 11:50:03 am »
I'm trying to work around this problem by loading the missing macro file from xretrace def_init if find_index doesn't find a particular function - dlist_construct   - but find_index says the function is in the names table but when I call the function, I get a slick stack.  Is it possible that a #import adds names to the names table and makes find_index return non zero even though the module containing dlist_construct hasn't been loaded yet?

Code: [Select]
   int vv1 = find_index('dlist_construct', PROC_TYPE);
   say("ggg " :+ vv1);

- the code above gives me 33104 but calling dlist_construct crashes.
 
For the plugin version of xretrace, I will probably have to load DLinkList.e from xretrace.e def_init every time xretrace.e is loaded.  It seems to work.
10
great, thanks.
Pages: [1] 2 3 ... 10