Recent Posts

Pages: [1] 2 3 ... 10
1
SlickEdit® / Re: Is the Qt5 Linux version of 26.0.0.6 available?
« Last post by patrickkox on October 23, 2021, 08:12:51 am »
Well in that case, I can confirm that it appears to work correctly on my Debian Stable (Bullseye) system.
2
SlickEdit® / Re: Problems with golang indentation?
« Last post by Clark on October 23, 2021, 02:09:11 am »
Smart indenting for Go is definitely not working as well as it should. We will look into this.
3
SlickEdit® / Problems with golang indentation?
« Last post by rr0 on October 22, 2021, 10:33:17 pm »
Hi Everyone, I’m a Slickedit novice & a registered Pro user for a handful of years now. I’m using Mac OS + emacs keyboard emulation.

For grins I’m trying v26 on a golang project that I’ve been working on. Set up the workspace & project and have triple checked the obvious language config settings in Google Go > Editing/Formatting, but indentation just doesn’t seem to be working for me. Indentation is working correctly in a C++ project, btw.

For example, this is what the editor is generating when I’m writing go code. Pressing tab doesn’t indent, either.

func testFunc(cfg initConfig) error {
if cfg.a != “” {
return errors.New(“hello world”)
}
}

What am I missing?
4
SlickEdit® / Re: Error trying to debug using integrated WinDbg
« Last post by Clark on October 22, 2021, 09:31:54 pm »
SlickEdit WinDBG support still has the same limitations.
5
SlickEdit® / Re: Error trying to debug using integrated WinDbg
« Last post by JeppeOland on October 22, 2021, 09:08:58 pm »
Is this still the case?
I'm trying to WinDBG a cmake generated project (2019 solutions, so it defaults to x64) and I'm getting the same error.
If I create a 2017 solution, it started up (but I promptly made SlickEdit lock up with a couple step into/step out of presses).
6
SlickEdit® / Re: Is the Qt5 Linux version of 26.0.0.6 available?
« Last post by Clark on October 22, 2021, 08:38:32 pm »
The Qt5 installers need more testing. The Qt5 version seems to be working for the hand full of beta testers that have tried it. It is unknown if the Qt5 installation will run on all of our customers Linux installations. We had to build this installer on a slightly newer version of Linux and it references more Linux library code. Also, we don't know whether there will be Window manager issues. In the future, we will either make both installers available from the website or just switch to the Qt5 version. No dates set.
7
SlickEdit® / Re: Is the Qt5 Linux version of 26.0.0.6 available?
« Last post by patrickkox on October 22, 2021, 07:55:43 pm »
Is there a reason why this version is not just made available through the "Registered Products" page ?
That would make it a lot easier since now with every update someone needs to come here and ask for the download link.
8
SlickEdit® / Re: What font is used for Syntax Expansion?
« Last post by jporkkahtc on October 22, 2021, 07:25:10 pm »
Changing "Tree Icon Size" changes the icons, but not the font.
Large icons get clipped - see attached showing "Colossal".
9
SlickEdit® / What font is used for Syntax Expansion?
« Last post by jporkkahtc on October 22, 2021, 07:21:05 pm »
I tried setting all the "HTML Controls" fonts to large, but the 1st level popup for syntax expansion is unchanged.
The 2nd level is affected by that change.

Changing the document font doesn't seem to do it either.
10
SlickEdit® / Re: C# 'using' statements being added.
« Last post by scottposch on October 22, 2021, 05:28:08 pm »
Thank you so much.
Pages: [1] 2 3 ... 10