Recent Posts

Pages: 1 2 [3] 4 5 ... 10
Features and/or Improvements / Version control configuration
« Last post by jporkkahtc on June 27, 2017, 06:00:44 pm »
Currently I have to setup version control for every project.

Make it possible to set a default version control for a workspace -- generally I have a workspace with a number of related projects, and all use the same version control.

Make it possible to set a default version control globally.

SlickEdit® / Re: 21.0.3 redefintion of pad-star
« Last post by jnairb on June 27, 2017, 03:58:09 pm »
Just loaded hotfix 3 and it reset my pad-star binding to c-asterisk.

If I open c.e in in my 21.0.3\hotfixes directory, I still see the PAD-STAR and PAD-SLASH 'c-keys' defs, despite the hotfix log saying that they've been removed.

What happened?
SlickEdit® / Re: Slickedit and cmake ?
« Last post by Mike on June 27, 2017, 03:08:52 pm »
We posted a new sticky thread here:,15318.0.html

The CMake 3.8.0 project generator on that page includes support for utility projects like the sample above.
SlickEdit® / Re: SlickEdit Hotfix Log
« Last post by Mike on June 27, 2017, 03:05:22 pm »
Revision 3 of the cumulative hot fix is available for SlickEdit v21.0.3.
Please be sure you have SlickEdit v21.0.3 before loading this hot fix!

There is a new cumulative hot fix for SlickEdit 2016 (v21.0.3) available on the page linked below:

All of the fixes in the cumulative hot fix are listed below.

Latest revision updates:

• javadoc.e -- Fix Javadoc editor where it could pick up arguments to a"catch" as method parameters in Java.
• c.e -- pad-slash can cause issue with key bindings users have made. The mode specific bindings for PAD-STAR and PAD-SLASH have been removed.
• debuggui.e -- Warn, but do not error out if we can not correctly identify the GDB version when adding a new GDB configuration.
• codehelp.e -- Fix Slick-C stack when trying to jump to a function prototype from mouse-over information.
• treeview.e -- Fix Slick-C stack when expanding certain tree nodes, generally in the Open tool window.
• ptoolbar.e project.e -- Fix Slick-C stack when using Cut/Copy/Paste in Projects tool window.

Previous revision updates:

• c.e -- c-asterisk command breaks the pad-star key binding for brief emulation
• tagfind.e -- Strip trailing spaces off of search string in Find Symbol dialog.
• autocomplete.e -- Fix a problem with completion that could cause extra text after the completion to be deleted.
• util.e -- Enhanced "man" command to use the current word if no parameters are specified so it can be bound to F1.
SlickEdit® / CMake SlickEdit project generator
« Last post by SlickEdit Support on June 27, 2017, 02:50:25 pm »
We have updated our CMake project generator to include more recent versions. Downloads are available at these links:




We have updated and rebuilt CMake to include dependent utility projects, but only for CMake 3.8.0. (See links above)

We only have the 64-bit builds available currently, but will do 32-bit builds on request.  Same for MacOS if someone needs it.

Use the generator option -G "SlickEdit - Unix Makefiles" or -G "SlickEdit - NMake Makefiles", depending on platform.  The SlickEdit generator builds SlickEdit workspaces and projects for tagging and navigation, and uses makefiles for builds.

If you have any issues or questions, please let us know by creating a support case at
That workaround is probably why we missed this was broken a second time - during development, those directories are unpacked; they get packed up when we build installers.  I'd bet I ran it on a dev install when I was testing it, and didn't realize it.
Presumably the testing process has been changed to block this from occurring in future?

Thanks Graeme.
Let me try those when the issue pops up again.
SlickEdit® / Re: Wishlist: git patch add
« Last post by Dan on June 26, 2017, 12:14:14 pm »
IMO git is so pervasive now SE should provide first class support instead of trying to shoehorn it into a generic UI.

What would you like to see.  We do have a generic framework, but have a Git repository browser, and I feel like the other features work well with Git, generic or not.
It could be a Windows 10 bug.  Have you got the win 10 creator's update?  Does copy/ paste work in other applications?  You could try this clipboard manager - the pro version is cheap.

Do you have Windows fast boot on?  If so, try turning it off and see if restart allows copy paste to work.

Have you tried restarting explorer?

To force a re-compilation of clipbd.e you have to "touch" the file to a make the "ex" file out of date.  It may not make any difference but you could try this macro to compile and load clipbd.e.  You might want to copy clipbd.e to a working folder of your own and load it from there to get round the write permission problem.

Code: [Select]
_command void force_load() name_info(','VSARG2_REQUIRES_EDITORCTL|VSARG2_READ_ONLY)

If none of the above helps you could try running the slick debugger and see what the paste command in clipbd.e is doing.  Also try upgrading to slick 21.0.3.

I am currently using Slickedit v21.0.1.0 x64 version on Windows 10.
Facing a problem where I am not able to copy paste after some actions. I think locking the system or putting it in sleep mode with Slickedit open cause this.

I can see the copied data in the clipboard but paste does not work. Out of 10 copies, it might work for once. That is it.
Once this problem  happens, none of the following works and I need to reinstall slickedit to get this working.
I tried system restart, deleting the slickedit config directory, and loading the clipbd.e module. (Maybe I am not doing it in some right way)

Has anyone faced any issues like this? Is there any workaround/fix for this? I am unable to use slickedit at this point because of this.

I found one thread similar to it but thread went idle without solution on v19.0.1.1

Pages: 1 2 [3] 4 5 ... 10